Infuse can't connect to SMB shares anymore

Hi,

I’ve recently noticed that Infuse doesn’t connect to my SMB-shares running on my Synology NAS anymore.
This issue seems to appear on all devices where I’m running Infuse ( iphone, ipad, appletv ).

I’ve already looked through the forums here at similar posts but haven’t come up with any troubleshooting steps that seem to resolve my issue.

Configuration:

  • Infuse is up-to-date with latest version available in AppStore for all devices
  • Devices are wirelessly connected to same subnet as NAS
  • Nas has wired connection with LACP enabled

Troubleshooting steps undertaken thusfar:

  • Reinstalled Infuse on all devices --> NOK, issue still present.
  • Created new share and tried to configure --> NOK, issue still present.
  • Reinstalled NAS, and recreated shares --> NOK, issue still present.
  • Tried configuring Infuse using all 4 SMB settings ( V1-3 and legacy ) --> NOK issue still present.
  • Disabled LACP configuration and tried connecting to both interfaces on the NAS using different IP-addresses --> NOK, issue still present.

I’m slowly running out of ideas as everything has been been either updated, reinstalled, or reconfigured.
Would anybody have any recommendations on what more I could try to solve this issue?

Thanks!

I have the same problem : not working for smb

I doubt this helps you, but Infuse still is able to connect to SMB shares on my Windows 7 box. At least you can know the problem is not with ALL SMB shares

1 Like

I also have the same issue whathever smb option I choose

Welcome to the forum and sorry you’re having problems.

Have you updated to the latest 6.5.7? If not please try that and also you may want to try restarting your ATV also since there were some changes to the SMB library.

Hi, I’m facing the same issue.

Connection to Windows 10 and FreeNAS SMB shares from Infuse on my iPhone and AppleTV works only intermittently. Sometimes it takes 1-2 minutes to open a folder (with very few items) or play files from the library or it brings up an error. Then again rarely it works as quickly as it used to. Configuration on the servers has not changed.

Restarting devices, deleting and re-adding shares or changing the SMB version does not alleviate the situation. Connecting from other devices or even my iPhone using the Files app works without issues.

Report code after trying to access a share and getting a “Could not connect” error: 7DGZM.

I hope this can get some attention and be fixed rather quickly as it affects the core functionality.

Your logs contain quite a few network related errors, both for the SMB shares and internet sources Infuse uses for metadata.

This usually indicates some sort of network issue (router, cables, etc…). If possible, I’d recommend checking all cables, restarting the router, and see where that gets you.

Thank you for checking the logs so quickly!

I did some more experimenting and it seems adding a share using an IP address instead of a hostname at least always lets Infuse connect to the share (even though it still takes some time to load). Adding the same share using a hostname results in a connection error (it loaded once initially after adding from the discovered shares section). Logs: PED5J. Share “dsa” with a hostname and “dsaip” is the same with its IP address if you can see the share names in the diagnostics file.

I am very certain it is not a general network error as all other apps and speedtests function without issues and Infuse itself on my AppleTV plays even large 4k files without hiccups once it has connected. I can upload diagnostics from there some time later.

I’d be happy to provide any other information if it could be helpful to nail this down, either a misconfiguration on my side, although this would surprise me as Files and VLC can connect every time, or some issue with Infuse.