Infuse asks me to Upgrade?

I have been on the yearly PRO subscription for several years (via Apple TV), but today when starting Infuse, it says that I must upgrade to PRO…

It won’t let me start any movies or TV shows, just shows the message to upgrade…

Please fix this ASAP. I am a paying customer!!

Have you tried restarting the ATV? It sounds like its lost the user id for the app store. Also make sure you’re still logged in to the same user ID that you subscribed with.

I’m guessing you may have just updated the tvOS since they released one recently. That may have scrambled things that a restart would fix.

I did restart. Same issue.

It worked until yesterday. tvOS wasn’t updated since yesterday.

If I look in the App Store, Infuse PRO is listed as a purchased App.

Then maybe sign out of and back into your account for iCloud and the app store on the atv. I’ve seen in the past where James has recommended this and it worked for others that Infuse didn’t recognize as a subscriber in the past.

Edit to add: Here’s one of James’ posts about that

Signed out and in, still no joy :frowning:

My yearly subscription was actually renewed today, so maybe something f****d up?

You say Infuse Pro shows as a purchased app, is it the version 6 pro or the version 5 pro? Also, you said you’ve been subscribing so you should be able to see your annual subscription in your account info for the Apple app store I think. If you have a purchase for pro that’s a different download than the free version that you can subscribe to for pro.

You can check your subscriptions and make sure it still shows in your account following the Apple users guide

I have the annual subscription for 6 PRO. It is shown in my account.

Do you have a “Restore” button in the Infuse settings?

Got it working.

Had to create a new ATV user, switch to that user and then switch back to the original user. Then it worked… Weird!?

1 Like

Weird would be an understatement. Glad you figured it out. :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.