Infuse App Constantly Waiting to Stream And Crashing in TVOS15

When the file size gets too large, it’s constantly crashing or failing to stream in Infuse. At first I thought this was a network problem, but plugging in an old PC to my TV, I was easily able to stream the same file sizes to the TV.

Looks like somethings going on with Infuse whereby the decoder can’t catch up with the images being displayed, and thus it has to stop and spin a while to restart it.

For example, i have Tenet, which is a 80GB movie, in TVOS14, I was able to watch it no problems with no hiccups, however with the new TVOS15 infuse, I cannot watch more than 2-3 minutes before it goes into hiccup mode.

Any idea why this is happening?

Here is the issue in detail:

It plays fine, then shows a spinner then plays the video without sound and then cannot play more than 10s afterwards and then crashes.

If you’re using the SMB protocol you may want to change to SMB2 or Legacy in the saved share advanced settings to see if that helps.

Will try that thanks. I’m finding that Windows to Windows share is totally fine, but Infuse seems to be the culprit. Again, only on these large file sizes.

The biggest problem is Game of Thrones at 30-40gb per 1 hour of video.

Changing it to SMB2 fixed it!!!

And idea why this was the solution?

Spoke too soon, smb2 and smb3 both seem to work for a bit, but then the app screws up again.

It feels like a memory leak or something

Switch to legacy. Often the overhead of SMB3 which often is defaulted to under auto is enough to cause slowdowns on high rate files.

Legacy is a different implementation that many find will solve this type of issue.

Also, how is the ATV connected to your network? WiFi or Ethernet? If WiFi, what band, 2.4 or 5G? If Ethernet, have you tried swapping to a new cable?

It’s connect via Ethernet.

With the latest update it seems like the game of thrones episodes have stabilized but the bigger videos still crashing.

Do you think cable actually creates problems.

Overall nothing has changed, only versions.

Here is the issue in detail:

It plays fine, then shows a spinner then plays the video without sound and then cannot play more than 10s afterwards and then crashes.

Did you try this?

One other thing to try after you try this is to change the “Streaming Cache” from Auto to Legacy in the Infuse settings under Playback.

I just tried legacy, and it is worse than smb.

Will try the streaming cache.

Again - check my previous post I updated with details.

That’s how it crashes.

Video stops, spinner shows, then video starts again with no sound and within 10 seconds entire video crashes and I have to exit out of the video to replay

Yup this is now a reproducible bug.

I can take a video and show you if that helps your team fix it

A couple more questions, have you done a restart on the ATV?

Also, what version of Infuse?

Yes, here is what I did to test:

  1. This has happened since TvOS15 update.
  2. The latest version of infuse (although has happened since Infuse 7).
  3. Updated to TvOS 15.1 RC, still happening.
  4. Restarted multiple times, still happening.

I’m currently going through my fileserver and doing a defrag and optimization. However, all my PC’s and Macs on network can play this videos with zero problems.

This only happens to large files, although it is weird:

The problem episode is Game of Thrones Moutain and Viper, when Aria walks with Sandor Clegane in the valley (so lots of background noise). The entire episode is 29GB

However, in Two Swords, this is fine, at 31GB, no problems however there isn’t huge movement.

Does this always happen at the same point in the video, or does it happen in more of a random fashion?

If it does happen in the same point, there may be something specific about these files that we may need to look into.

If you’d like to upload a sample (any size), you can submit one here.

It doesn’t seem to do it at always the same time, sometimes it does, other times it does not

I just want to update the team - I downloaded the new 90GB Dune Remux, and it plays flawlessly so I don’t think it’s go to do with my wireless internet bandwidth.

What seems to happen is if you play certain videos (specific codecs maybe?) long enough, it somehow hiccups, or runs of out of memory - then it buffers, then plays without sound for 5-10 seconds then the video crashes.

It hasn’t happened lately, but I will see if it happens again on a different video.

Again, the 90GB dune plays flawlessly for the entirety of the movie, so I’m sure it’s not a bandwidth problem. Will try to continue help diagnosing this problem.