Infuse and Plex: what's happened since 25/05?

Hi!
First of all, sorry for the long post.
Second, a little background to better understand my situation.
Then, my actual issues.

So let’s start!
I’m running Plex Media Server (PMS from now on) on my QNAP NAS since years, I’ve carefully created proper library items (Anime, Cartoons, Movies, etc), carefully selected proper audio track (I’m from Italy, all of my 14k files have italian audio track (for some file PMS shows “unknown” since the track is not proper marked as “Italian”), most of them also have english audio track), carefully selected proper subtitle track when needed (the so-called “forced subtitle”. not in all files these subtitle are marked as “forced”, so I manually selected the correct one for all my files).
I used to watch my files on an Android box (Minix U1) with XMBC + the official Kodi plugin made by Plex (it’s still in early stage, like version 0.102 or whatever). I quite enjoyed this setup but had minor issues (video quality was little below my expectation, some quirks when jumping to next episode, and the like) but since I really wanted to go “full Apple” (I already owned an iPad Pro 10.5" and an iPhone 8 Plus), when I read that Infuse had added Plex integration I immediately bought an Apple TV 4K, purchased Infuse and the lifetime pass (I’m already a Plex lifetime user).

So, since 21/04 to 25/05 my only complaints with the new setup (Apple TV 4K, Infuse on all my iDevices, Plex as the only source) were:

  1. the audio and subtitle tracks I selected in PMS are completely ignored by Infuse. Infuse always goes to the first matching audio track of system language (italian) or fallback to english when it can’t find one (remember, some of my files have the italian audio track marked as “unknown”). For subtitles, when I choose “show subtitle” in Infuse settings it always shows the first “full” subtitle track, never the “forced” one. when I choose “don’t show subtitles” Infuse never shows subtitles (seem obvious) even if I read in this forum that with this setting Infuse should show the “forced” ones. So in the end, I have to manually select the proper subtitle track file-by-file while I’m playing it, even if I already did all the job in PMS
  2. the iCloud sync never worked for me. Example: I’m watching South Park. I start watching season 1, episode 1 on the iPad. Then I turn on ATV, it shows that the next episode is the second (correct, it grubs current episode from PMS). I watch the rest of the first season on the ATV, then Infuse won’t automatically go to the second season (official Plex app does this obvious (for me) step). I digged into my library to start watching the second season, and I watch the first episode. When I went back to my iPad, it still showed the second episode of the first season to watch! No “sync” at all. I digged into my library, started to watch S02E02, and after that on the first row I had two “poster” (or whatever are called) of South Park: one for season 1 episode 2 and one for season 2 episode 3. Why? My only source is PMS, it should be in sync with PMS if not with the ATV through “iCloud sync”!

anyway, the first issue is just boring, the second is weird, but since I mostly watch my stuff on the TV, I could ignore it.

Then 25/05 kicked in and everything start to behave in such a strange manner.
First, on ATV I lost all my favorites, but since PMS was the only source I haven’t really “lost” anything. I simply re-added my favorites and moved on.
That loss happened two-three times, then I read here that there was some strange iCloud issue (that hit only Infuse for what I know), so I disabled iCloud sync on all my devices.

On 30/05 Apple released iOS 11.4 and tvOS 11.4. I immediately updated all my devices. When I run Infuse on my iPhone/iPad I had no issue, on my ATV Infuse just crashed on start. Then I deleted (from my iPhone) all Infuse-related files saved in iCloud, then I tried to start again Infuse and this time worked.

Then on 31/05 Firecore released the 5.7.2 update and:

  • on all my devices, the first row where I used to find the “currently watching” shows disappeared (I loved this feature). There were only the giant “Infuse” logo that took away half of the screen
  • on all my devices Infuse start to download again all metadata-thumbnails of my 14k files.

So I tried to:

  • delete everything from iCloud again (even if it’s turned off, I found again some Infuse data (about 9kb) in my iCloud)
  • deleted the app from all my devices
  • reinstalled the app on my devices, one after one: on the first run I immediately disable iCloud sync, then I added the PMS as my only source as before, waited for Infuse to download all metadata-thumbnails.

Again on all my devices the first row with “currently watching” shows is empty. I can see something if I choose “On” or “Recently added”: both settings really show recently added content only. The only way to see something I’m watching is to start watching an episode on a device, stop it, bring another device, open Infuse and (since it grab the status from PMS) that episodes pops in in the first row.
So, why on the top rows there no more the “currently watching” shows? It was a neat feature. I know I can add the PMS “On Deck” to my favorites, but it’s not the same. This thing has effect even on the ATV “home page”: before 5.7.2 when I selected the Infuse icon on top of the screen there were the “currently watching” shows, now it’s empty and there is only that Infuse giant logo. The Plex official app never had issue with iCloud/11.4 or whatever (Plex’s app has issue with file format, we all now this, that’s the first reason everyone with an ATV buy Infuse).

I add some screenshot from my iPhone and some photo of my TV (I don’t know if it’s possible to take a screenshot from the ATV 4K) to help check if I’m missing something in the settings or not (sorry, everything is in italian but I think all is understandable):

iPhone:
no more “shows” on the top row: https://ibb.co/n43n2d
my library: https://ibb.co/i781dJ
my settings: https://ibb.co/kqzJQy and https://ibb.co/gKo1dJ

ATV:
Plex on the ATV home page: https://ibb.co/ninNky
inside Plex official app: https://ibb.co/irA8Qy
Infuse on the ATV home page: https://ibb.co/c6Va5y
no more “shows” on the top row: https://ibb.co/mAsuyJ
my settings: https://ibb.co/hL0EyJ, https://ibb.co/isZwCd, https://ibb.co/iuGnJJ and https://ibb.co/do1nJJ

so, in the end, am I doing something wrong? Is all of this an expected behavior of version 5.7.2? Will Infuse have a better support for audio/subtitle track selected in PMS?
thanks for your patience, if I read all of this! :smiley:

Have you seen this thread that is tacked at the top of this forum Lost all Favorites, Up-Next, etc. ?

It explains what caused the loss of shares and data around the 24th ( and the subsequent return after a few days in many cases)

This thread was locked but still has the pertinent info mostly updated by James in the first post.

There are also instructions on how to restore the lost lists and favorites.

Yes, I read that thread (I even wrote some posts) and I used those information to try to bring back Infuse to “normal” behavior.

I’m not sure this will answer your question but when you’re watching a tv show using Plex integration it won’t show the next episode available on Apples top shelf or the up next list ‘watching’, instead you will just get an on deck list on the infuse homepage, I remember firecore saying that they tried to implement Plex on deck in the up next list ‘Watching’ but they ran into trouble so had to make a separate list. I know this feature works for smb/nfs shares though and it will show you the next available episode on Apple top shelf and up next list.

There is a trick though just watch 1 second of the next episode and stop it and the tv show should pop up on Apples top shelf and the infuse up next list ‘watching’

I’m hoping infuse will add on deck to Apple top shelf in the future.

But I had the next episode both in ATV home page when I selected Infuse’s icon and inside Infuse prior 5.7.2!

Yes I know but 5.72 added Plex on deck list and now this is the behaviour of infuse when using Plex integration if you want to continue a tv show, before 5.72 infuse was not in sync with the Plex server when Continuing a TV show/movies.

I’m just helping on how it works, hey I would love the continuing watching ‘on deck’ on top shelf too and on the up next list, but infuse had trouble implementing on deck with it.

As I said one trick you can do is watch a second of the next episode and stop it then your tv show will pop up on Apples top shelf and infuse up next list like before 5.72.

Hopefully infuse lets us re order our lists as well therefore you can place on deck right at the top, I know this is on their to do list.

1 Like

so something that worked (with 5.7.1 Infuse showed “currently watching shows” both on top row inside Infuse and on the ATV home page) is now “broken” (with 5.7.2 you just get that giant logo)?
such a shame! :frowning:

I’m not sure how you got “broken” from that it’s just a different implementation for Plex integration since they had trouble adding on deck to the up next list therefore added a separate list. You won’t get that giant infuse logo if you have continue watching items like stopping a movie or tv show halfway, or recently added items if that’s turned on.

Who knows firecore might add on deck to Apple top shelf in the future, maybe you should suggest this in the suggestions thread.

It’s a bit like collections doesn’t work with Plex integration but works with smb/nfs shares, it doesn’t mean it’s broken just means that the current way of implementing collections isn’t compatible with Plex integration .

Hopefully infuse staff will reply to you about this, not sure what else I can say.

Sorry, maybe I can’t explain myself. Bad english maybe. :slight_smile:

I meant:

  • with 5.7.1 on the top row inside Infuse there were shows I’m currently watching. on ATV home page selecting the Infuse’s icon you were presented with these shows
  • with 5.7.2 they added “On Deck” support and we lost the above. Are these options mutually exclusive? Can’t we get both? Or at least give us an option? It’s “sad” to see that empty row inside Infuse or just the logo on ATV home page

It would be nice to re-arrange rows inside Infuse: if so I definitively move the “On Deck” row to the top, since now the interface is, well, quite empty.
my two cents.

Sorry i can’t answer if they’re mutually exclusive or not someone from firecore will have to answer that. All I know is that they wanted to add on deck to the up next list but had trouble implementing it that way so made a separate list.