Infuse and Homepod home theater - sound issues


I have updated my homepods to 14.2 and connected them to Apple TV. However, the sound output from infuse 6 Pro sounds terrible over homepod: the volume is very low (I have to crank up the homepods’ volume and use audio boost), and the sound just sounds off, as if it’s bouncing around between the speakers and lacking brightness and midrange (the sound is very flat and muddy). Also, there’s is noticeable lipsync.

Now, this problem only happens with infuse. If I play the same video using Plex, the volume is much higher, the sound is balanced and dynamic and does not “bounce around”, and the lipsync is perfect. (Additionally, sound on the homepods is excellent when playing from Netflix or Apple TV+).

The sound output of Apple TV 4k is set to “auto”. Everything is on the latest software version (Apple TV, Homepod, Infuse). I have an infuse pro subscription. This files are hosted via my plex library. The problem above happens both for Dolby Digital Plus as well as TrueHD encoded video files.

Please fix this so I can enjoy watching my videos using Infuse, which I prefer to Plex. Thanks!


Yeah I noticed this too. And the problem is that infuse is still treating homepod as Airplay instead of a Speaker. If you go to the audio on infuse while playing a movie and you can clearly see it.

I’ve attached pics for better understanding.![

Image 1:
Image 2:

The first image clearly shows my TV speakers as Speakers, but the 2nd image shows homepod as Airplay…

Please fix this guys

1 Like

Same problem. I hope it will be fixed soon.

Have you tried scrolling down on the audio tab in your pics and clicking on the “Speaker” when it’s highlighted? I believe it may give you the option to select differently.

there isn’t any other option. There is Apple TV+Homepod in one and only option and it’s already chosen.

I was replying to the poster than provided the screen caps and in theirs it shows airplay.

Does yours show AirPlay or HomePod?

1 Like

I can confirm similar problem. Only see Airplay

Can you provide a screen cap of what you’re seeing when you click on “Speaker” under the audio tab while playing a video?

1 Like

Pretty much same result as the person above, when I click on Speaker “Airplay” , I see my stereo home theatre mode Homepods.

What happens when you click when the word Speaker and AirPlay are highlighted? It should take you to another screen.

I did add that photo too in my linked album above, it just shows my already selected homepods

Sorry I must have missed it the first time.

I’m working in the dark here since I don’t have the HomePod speakers but do I understand correctly that you are having low volume issues in Infuse?

If that is correct, I see on your screen shot where it allows you to adjust the volume with the + and - keys. Have you tried that? I don’t know if that’s a universal setting for all videos or not but that may help.

1 Like

No worries! So those + - options are available for everything, that’s pretty much the volume control.

I can agree that it’s got low volume but more importantly I don’t believe that the correct channels are being outputted either. I tested this in comparison with a DDP track on my HomePod and the same on Netflix, the Netflix audio was much fuller, had spatial and wider feeling audio where I could recognize left and right quite easily.

We’re going to look into this and see what might be going on here.

Can you confirm the poor sound issue is new since updating to tvOS/Homepod 14.2?

1 Like

I can’t say for sure if it’s exactly after 14.2 as I got my homepods just recently and they were stereo and 14.2 so I wouldn’t have a version comparison. I however can comment for sure that it sounds way better in Netflix compared to anything I play on Infuse. Similar feedback as the OP.

1 Like

I have the same issue. Two days ago I found infuse and I really like it after many years of plex. I didn’t noticed a sound difference with the stereo bookshelf speakers but today I bought two homepods to test the new improved sound but in infuse sounds very flat and low. On plex, netflix or apple tv+ sounds great.


Not only does HomePod Apple TV 4k output via infuse sound flat and low, it also sounds “distant”. It’s as if you can’t place where the sound is coming from (the center channel isn’t virtualized well).
While the pulldown menu shows “airplay” when the HomePods are connected to Apple TV 4k as sound output, when you click on the speaker selection, it says that the speaker output is indeed Apple TV.
When I do not connect HomePods to Apple TV, instead actually using Airplay to play to HomePods the sound is also distant and low, and additionally lip sync is gone. (Sounds just as bad as when HomePods are set as the Apple TV audio output, but also the lip sync is off).


Thanks everyone for confirming the issues and getting infuse to notice! Hopefully we all will get a fix soon


This may or may not help but Apple today released new 14.2.1 software for the HomePods so it may be worth a try.

1 Like

I just updated. This did not help — the problem persists.

1 Like