Infuse Airplay no longer working on Roku devices

Like the title says my Infuse Pro account and library was working perfectly with my Onedrive and airplay through my Roku devices up until about 2 weeks ago, since that time i haven’t been able to use the airplay function, as it continually is in a loading stage. FYI i use wired internet and a fibre optic connection so internet speed shouldn’t be the issue.

1 Like

Is this affecting all files or just a few?

Does playback work in the Infuse app, just not via AirPlay?

so this has affected all files, and no it works perfectly fine playing the media from infuse on my phone. Just when i try to airplay to my roku it no longer works, just stays in that loading stage

2 Likes

@james I have exactly the same experience. Stopped working for me a few weeks ago. Tried iPhone and iPad and also did a factory reset on the Roku. My Roku reports excellent wireless signal strength and I have 50mb down and only streaming 480p files also cloud storage with One Drive.
Thought it might be fixed with the release of 7, but sadly not.
Can airplay music or videos from safari for example so airplay is working.
Would love to know if this is a known issue

I installed Infuse for the first time a week or so ago (version 6.6) and have since updated to version 7. In the meantime, my Roku Ultra has self-installed a firmware update. Through all of this time, before and after all updates, Infuse has refused to play any of my Mac-standard video files, via AirPlay, from my iPad Air to my Roku Ultra device/TV screen.

I have tried tweaking every setting I can think of (in Infuse and on the Roku device) that might possibly have an impact – but nothing has helped in the slightest. Every time I start playing a standard MPEG-4 file (h.264 codec, MP4/M4V container, with AAC or AC3 audio), on my iPad and try to start AirPlay to my Roku Device, my TV switches to the AirPlay screen on my Roku Ultra and then shows nothing but a spinning wheel (buffering?), endlessly. Sometimes, my screen will flash an image of the video’s thumbnail and its title on the screen for about one-half second before the spinning wheel shows up. I have waited as long as five minutes before giving up on any video ever presenting itself on the TV.

Oddly enough, when I have tried to AirPlay an old AVI file (with, say, an XviD codec and MP3 audio), Roku will treat it like a straight-on audio file and play it like one (the audio portion plays successfully with the thumbnail and title on screen). AirPlay through Roku, though, seems to be completely incapable of playing AAC or Dolby Digital audio. (I have turned off “5.1 Audio over AirPlay” in settings.)

I applied for the 1-month free trial of Infuse, which will convert to a paid one-year subscription next month – if I can get this issue settled. The main reason I installed Infuse in the first place was to be able to AirPlay my videos on my television (!).

I hope someone there can find a fix for this problem.

I thought I was going crazy when I got my new roku TV with airplay. I can airplay mirror and airplay from all other apps. Infuse its just stuck at the initial loading screen. This was a standard 264 file, plays fine on iPhone.

Im experiencing the same issue. I subscribed to infuse only to airplay videos to my roku. It worked perfectly the first 2 weeks but it suddenly stopped working some weeks ago. Now that I see that this issue was reported long ago I think it would be time to find an alternative…

Welcome to the forum!

I can highly recommend the Apple TV 4K. :smiley:

I think Ffonts21 meant it was time to find an alternative to Infuse, not a replacement for his (or her) Roku :exclamation:

It’s been nearly three weeks since this thread was started and not a single word from anyone about a fix. Developers generally keep an eye on their products’ forums and are often in communication with the moderators of those forums. If that is the case here, it doesn’t show.

I would think Firecore would be anxious to fix this bug as quickly as possible, as customers (like me) are ready to jump ship without this feature working. If there is not a fix (or a posted ETA for one) by the beginning of next month, when my trial period ends, I will cancel my subscription before I am charged for it and delete Infuse from my iPad. That’s not meant to be in any way unkind, it’s just a simple fact. Customers do not remain loyal to products that don’t work the way they’re advertised to work.

This is on our radar.

However, AirPlay to Roku devices was something which was never officially supported…but it did seem to work for some people.

It seems Roku may have changed something in a software update, and this will be looked into.

1 Like

Thanks for the update James. I suspected from the timing that it was related to updates by Roku. Strange one. With my limited knowhow, I assumed AirPlay implementation was standard across all devices, Apple or otherwise, but clearly not. At least with the introduction of Infuse for Mac I’m able to placate my Partner slightly, she loved falling asleep to her fave old movies we have on Infuse, now we do that on the MacBook instead.
Hoping for a resolution though, as she still prefers to watch on the tv. Thanks

This is possible, certainly, but since AirPlaying videos through my Roku Ultra to my TV still works fine from my iPad when I’m using the YouTube app or Safari or Apple Photos (and maybe others) I had to assume that the problem here was with Infuse, not with my Roku device.

It is encouraging to learn, though, that Firecore is actively looking for the cause, even if it may take longer than I can wait before cancelling my subscription. Good luck in finding it. :slightly_smiling_face: