Infuse 7 crashing on Apple TV

Hello, after upgrading to Infuse 7 it is unusable on Apple TV for me. It is starting and after a few seconds it will close itself. Unfortunately I haven’t found a way to downgrade to Infuse 6 so at the moment it is unusable for me.
Btw - my Apple TV is running on tvOS 14.5.

1 Like

For reference what model of Atv do you have.

I have an Apple TV 4K

Have you tried restarting the ATV?

i already tried restarting the ATV. I even uninstalled and reinstalled infuse 7 with no luck.

I have seen this symptom in the past and it has usually been some sort of iCloud problem.

Try turning off iCloud in that main ATV settings (not Infuse settings): Settings → Users and Accounts → Default User account → iCloud → Sign out.

Then start Infuse … hopefully it should now start up OK.

When you are confident the Infuse is no longer crashing, go back and re-login to your iCloud account.

The iCloud tip did not solve my problem. But I have done some troubleshooting and it seems it is caused by the “Pre-Cache pictures” option in the advanced settings of the Emby options. When uninstalling and reinstalling Infuse 7 it starts and if you add an Emby Server with “Pre-Cache pictures” option the problem starts again - if you disable the option it seem to work now :blush:

The same here!!!

I have apple tv 4K (14.5), apple tv HD (14.5), iphone (14.5) and ipad (14.5) and Infuse crashes when start the app.

I have connected Emby.

1 Like


Same here.

Infuse 7 crashes after a few seconds on apple tv 4 (14.5) connected to Jellyfin 10.7.2. (icloud sync is not activated in infuse because i’m using jellyfin)

I tried to deactivate “pre-cache images” in the infuse jellyfin settings, but did not helped. Infuse is still crashing.
EDIT : i’ve deleted the Jellyfin connection in infuse and recreated it with the “pre-cache images” deactivated, and it is working now.

When apple tv is not connected to the network, infuse 7 is not crashing.

1 Like

Sorry for the trouble, but thanks for all the reports here!

We have a fix for this coming in 7.0.1 which we’ve submitted to Apple today.

Should hopefully be live on the App Store within the next few days. :crossed_fingers:

In the meantime, editing the Emby share and disabling ‘Pre-Cache Images’ is a workaround for now.

I had it crash at first as well with Emby, didn’t want to delete and re-add Emby, thought I would leave it a few days till the update came out, but a few hours later ran it again just for kicks and it came up, precached and all.

7.0.1 with a fix for this issue is now available on the App Store.

Thanks for your patience. :slight_smile:

Thank you very much @james !

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.