Infuse 6 pro over VPN not working (SMB)

Hello

I know there are threads about that issue but on infuse 6 pro there’s no solution for this issue!?
When i’m @home and connected to my home-network everything just works fine.

When i’m away and connected to my home-network over VPN (fritzbox) all other services/connections to my home-network are working fine, but why is infuse 6 pro unable to stream any video!? It seems there’s no connection, the app/library isn’t checking for changes too.

Has someone a solution for this or a workaround?

Thank you and best regards
Marcel

Am i the only one with the VPN problem?!

Are you able to connect via SMB using other apps while using your VPN?

It looks like remote access for certain ports (including the default SMB port of 445) may be disabled (https://en.avm.de/service/fritzbox/fritzbox-7581/knowledge-base/publication/show/835_Shared-files-and-printers-on-a-computer-are-not-available-over-the-internet/) but in Infuse 6.0.7 you can specify a custom port for SMB, which may allow this to work.

Hello james

Thank you for your help!
You’re right, was not able to connect to SMB with other apps/services.
So i removed sharing over SMB and added a new sharing over NFS with the IP of my NAS.

Now i can watch movies over VPN outside my network.

Great! :smiley:

Thanks for following-up.

Hi, thought I would post here give one possible explanation for this problem, which affected me the same way as the OP. I added an SMB share from my QNAP NAS to Infuse, which worked fine while connected over the home network but didn’t work over VPN (OpenVPN). When I looked into it, I had added the share from the “Available Shares” section of the Add Files dialogue, which works over Bonjour/zeroconf. So the share had an address of the form [sharename].local. Unfortunately that address can’t be resolved over VPN in most configurations, because multicast DNS packets aren’t passed to the VPN client. So the share worked at home but not over VPN. Changing the share to use the NAS IP directly fixed the problem same as the OP, but it’s not an SMB or Infuse problem (i.e. changing to NFS was just a coincidence). In theory you can set up the VPN to work with Bonjour, but it’s probably more hassle than its worth.

Hello

I have been having problems setting up a way to remotely view content from my NAS via infuse.

I have been told that “webdav” is the best connection so I have been using it. Viewing content at home is not a problem.
I port forwarded my router to 5005 to view the content but my the external IP address keeps changing. (very annoying)

I am guessing a VPN would work best but still I have problems setting up.

Can you help me with a detailed set up.

many thanks in advance.

maddict

A detailed setup probably won’t happen as it’s time consuming to write up and for me personally I’m not getting paid for it. If your IP address keeps changing subscribe to a DDNS service and use that address to connect to.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.