Infuse 6 pro: 4K playback

Hello community!

I’ve been a happy user of Infuse 6 pro since the last 8 months, ever since I’ve purchased it as a standalone version through the Apple App Store.

Lately I’m experiencing issues with this player. I’m using it alongside my Plex server. 1080p footage is being played without any issue, but whenever I’m trying to play 4K, Infuse is starting the movie, but after a few seconds the spinning circle appears.

In the past I had this a few times but after restating the movie, it was solved. Lately this does not see to help.

I’ve tried the following steps:

  • Restarting and updating Plex server.
  • Deleting ‘cache’ in infuse
  • Restarting Apple TV’s
  • Testing internet speeds and connectivity
  • Deleting Infuse on Apple TV and reinstall it.

Still this issue appears on both my Apple TV’s, running tvOS 14.7. The connection is very well with a 380/38 mbps download and upload speed - using a wired connection on all devices.

Before it all worked flawlessly. I’m suspecting it has something to do with Infuse itself as Plex player can play the same 4K files, but I do prefer Infuse.

As I’ve purchased the pro version of Infuse 6, I want to use it as long as possible. If upgrading to Infuse 7 would be a solution, I might consider it.

Firstly I would like to know if anyone else is experiencing likewise issues ever since the last few weeks.
Secondly, if so - what can be done :wink:

Thanks in advance!

Welcome to the forum!

There was a tvOS update or two within the last few weeks so that too may be part of the cause.

There is also a currently running thread where tvOS 15 appears to be causing issues with 4K files here.

1 Like

Also, unless your streaming from a remote server the internet speed doesn’t really come into play for playback.

There is a speed test in Infuse under the setting if you go to Shares > Saved Shares > Select the share you want to test the speed to > Speed Test

As NC mentioned, you can try running a speed test within Infuse as this may provide some insight as to what’s going on.

Also, if you want to give v7 a try to see if things are different there you can get a free 1 year trial.

1 Like

Thank you for your insights. It has helped me to find what was wrong.

After doing speed tests, I noticed that the speed was very low of some of my videos. I change all of my cables and restarted my modem and router, switches, etc.

After a while, I figured out that all the slow speeds were only on one particular drive. A separate disk test showed a very low read score (3 mb/s) on that particular drive, while it was a new ssd drive from a few months ago.

I’ve replaced that sata cable. The speeds are now high enough to play my videos, like they should.

I’ve also upgraded to infuse 7.

2 Likes

Awesome! Thanks for following up. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.