Infuse 6 missing files and folders on NAS

Thanks in advance for your help. It’s along post because I wanted to include a detailed description and also the diagnostic steps I’ve already tried.

I have a folder for movies and a folder for TV shows on my BuffaloNAS. In the main movie folder, each movie is in a subfolder so the subtitle files (if any) are in the same folder. In the main TV Show folder, each TV series is in its own folder by season (e.g., the Game of Thrones folder has subfolders for Season 1, Season 2, Season 3, etc.)

When I open Infuse 6 on my ATV4, it doesn’t see some files and folders. Here are two current examples:

  1. I have Game of Thrones seasons 1 & 2 in the GoT folder. All files are same format in MKV containers with SRT subtitle files. Infuse will only show the folder for Season 2, and does not show the folder for Season 1
  2. I have a folder for ‘True Detectives’ Season 3. All files are same format and container. Infuse doesn’t show Episode 1. Shows everything else but Episode 1.

I know enough to fix most problems, but I can’t even guess why the system would not be able to see files of identical format in the same folder.

So I did some diagnosis:

  1. I opened Infuse on my IPad, went to the shared directory on the NAS and saw the same thing I saw on the ATV4
  2. Then I opened VLC Player on the iPad and noticed it showed TWO VERSIONS of my Nas. One version was uPnP and the other version was SMB
  3. When I tried to look at the uPnP share version in VLC, I got the SAME RESULT as with Infuse. The same files and folders were missing
  4. But when I looked at the SMB share version of the NAS, ALL THE FILES AND FOLDERS WERE THERE.
  5. The NAS is the same NAS, but VLC could see all the files if I selected the SMB version of the NAS in the menu

I saw the Infuse “How to” pages about enabling SMB on various streaming devices, but it must already be enabled on my NAS because VLC saw it and categorized it as SMB share.

I’m guessing the solution would be to enable SMB (something) in Infuse so that Infuse can see all the files and folders like VLC.

Might be an oversimplification but it’s all I’ve been able to think of.

Please advise.

Welcome to the forum!

In some cases, streaming via UPnP will provide a different list of files compared to SMB.

If you navigate to Settings > Shares do you see this device listed under the available shares list? If more than one connection option is available, Infuse should list the type in parenthesis EG My Nas (SMB) and My Nas (UPnP). However, if you already have one connection set up, the second connection may simply show the share name, and not the type.

If possible, connecting via SMB should allow Infuse to get access to all your videos.


Thanks James. By combining your feedback with info from other posts, I was able to solve the issue:

  1. Infuse did NOT show another SMB version of the NAS server when I searched shares
  2. But it did give me an option to select “Other”…
  3. When I selected “Other” I came to a screen I had seen in other posts
  4. I could give the share a name, select the streaming protocol (SMB) and the IP address of the NAS
  5. Critical piece was to select SMB1 in the next screen when the system asks for the version of SMB (also learned from a different post)
  6. Then I deleted the old share and OMG it is like a different app!! It shows cover art, currently watching, recently added, automatically separates movies from TV shows.

I didn’t realize the app was this …beautiful.

While I wish the “how to” section on the website had more detail, I’m grateful we have a forum to help people walk through these issues.

Many Thanks,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.