Infuse 6.0.8 slowly buffering on one of my ATVs.

Hello! Longtime lurker, first time poster, (thanks to everyone for the great questions and answers, you’ve all been really helpful!).

I’m absolutely in love with Infuse and have been using it for around three years. My current setup consists of two ATVs (one ATV 4 and one ATV4k). These are wirelessly connected to my eero router, which has a WD MyCloud connected to it. Infuse Pro (lifetime) is pointed to that MyCloud with an SMB connection.

Prior to Infuse 6 I had the occasional buffering issues with files larger than 15gb. I was thrilled when Infuse added the read-ahead buffering because it solved my only occasional issue. The Infuse on my main tv, the one with the ATV 4, buffers perfectly. When I pause a movie I see the grey line out ahead of the playback and I never have an issue. I’ve just started utilizing my other tv a bit more, the one with the ATV4k, and I’ve started running into constant buffering issues. It’s updated to the same version of Infuse, it’s setup the same way, and pointing to the same files on the same network. For any files larger than 1gb I get the circle every couple minutes. For any type of buffering to occur, I need to leave the movie paused for 10+ mins to get just a few minutes of buffer time. Obviously that COULD be a network issue, but both ATVs show a perfect signal from my router, so I don’t THINK that’s the issue.

Does anyone have any suggestions I should try? Like I said, I’m almost positive I set both ATVs up identically, but I’m willing to have a look if anyone has suggestions. Thanks for the help!

(One other side note in case it matters, I had to disable the 4K playback settings in Infuse on this ATV4k. For lack of a better explanation, the Infuse playback looked like it was constantly dropping frames, but immediately cleaned up after I set the playback to 1080p. 4K ATV, 4K file, and 4K tv. I’m less concerned about this right now but in case it matters to the other situation). Thanks!!

Glad you decided to join the forum fun!

Sorry it’s for a problem, what do you have your SMB set for on the 4K? Legacy, Auto, 1, 2, or 3?

One possible test is to temporarily for testing purpose is to string a Ethernet cable to the 4K and see if that eliminates the issues. WiFi is voodoo and can show good and be poor in use.