Infuse 5: Watched Indicators "Broken"

I just downloaded Infuse 5 yesterday and re-set up my shares, etc… I was marking several videos as watched that I’d already viewed under v4. When I went to a different app and then later came back, I noticed that some of the videos I had marked as watched had indicators on them again, showing I had only watched part of the video. When I clicked them to play, it would ask me if I wanted to resume from 00:01. :-/ I marked them as watched again and some stayed and some didn’t when I would come back.

Also, it seems like if I choose a TV series, for example, from the “Up Next” bar it will immediately mark some of them previously watched episodes and partially watched yet again.

John

I noticed the same. Some epidsodes I watched yesterday showed the indicator as I went back in later, also asked me to resume from 00:01.

I also noticed that some of the episodes I’ve watched were marked as watched in my WatchApp (iPhone, I sync via trakt.tv), some were not marked.

To avoid that, is better do a clean install, delete the share and metadata and uninstall the app reboot and install the app from 0

This WAS a clean install. Infuse 5 doesn’t install over old versions. It’s a bug in the app apparently.

Sorry about that

Is there any update of fixing this in 5? Getting a little old having to go back and remark shows as watched.

This is a repeatable bug in 5, I can watch a show, verify the watched indicator is ticked and leave infuse then go back and it shows that watched show as :01 second watched and asks to continue from there.

I don’t know what is your setting and hardware, but i don’t have any issue

Do you have a Pal screen?

Nope, not a PAL screen. This is only happening on Pro 5 not Pro 4.

Looking for an update from FireCore regarding this bug.

Weird, my issues are gone away with the 5

Yes, this is bug continues to exist. I would have thought it was something to be fixed quickly given how basic of a future it is, let alone that it wasn’t caught during beta test is surprising.

How about it James, any update on this?

We haven’t been able to replicate the issue here, and so far have only had 1 or 2 reports of this. We had a few similar reports in v4, and it turned out to be related to the Apple TV running out of storage space.

There are a few things to check which may help.

  1. Check Apple TV free space (Settings > General > Manage Storage)
  2. Remove other copies of Infuse
  3. If logged into trakt, try logging out then back in
  1. My Apple TV doesn’t list free space but from what I can see from the numbers listed, I’ve installed around 500MB worth of apps.
  2. only one copy of Infuse here. (Infuse 4 was still installed when I installed 5 but it was removed the first day)
  3. Haven’t been using Trakt at all with Infuse.

Erm, what has screen resolution or refresh rate have to do with the watched indicators working or not?

I’m sorry, but your posts seem to be very random in their advice… As a beta tester, you should know full well that an installation of Infuse 4 has no bearing on an installation of Infuse 5, they are totally separate apps, share no common runtimes, executionables, resources or storage links within iOS.

I don’t think you have a storage space problem, I have over 6000 movies and TV episodes, and Infuse takes up about 30Mb of storage space for it’s DB.

One thing I have noticed with Infuse, is that it seems to only mark an episode or movie watched, if you have watched almost the entire thing. I don’t watch the credits at the end, and when I press stop, and Infuse goes back to the info screen, it often says that the file I have just watched is unwatched, so I end up manually pressing on watched in cases like that. I find that Infuse marks things as watched much more reliably when you watch the file to the end, and Infuse stops playback itself.

Another thing, is that if you don’t use Trakt, Infuse will still mark things as watched, however if you use another device, or end up re-installing Infuse, then there is nothing to tell Infuse about what has been watched or not. I use Trakt without any problems.

In most cases I let shows run until they finish and those will appear as watched right afterwards but when I later return they are marked incorrectly again.

This is just as true if I manually mark something as watched. When I return its back to being partly watched and asks if I want to resume from 00:01 IIRC. I never saw this issue with version 4.

any update on this ?
Having the same issue, whereas episodes are marked partially watched (not necessarily 0:01, but anywhere on the timeline) whatever I do.
I can go and mark all episodes as watched and when I come back to infuse they are at the same partially watched state again … feels like this “database” is read only.
The media itself is on a SMB share.
Since I have iCloud-Sync set to on, I assume that iCloud never get’s updated and therefore overwrites the local marks when coming back.

Best, P

I think early on I tried turning off the iCloud syncing and it made no difference.

yep, just tried without iCloud-Sync … same issue.

marked indicators change back randomly to an earlier state, even after just browsing through some other folders and coming back.
This is seriously broken …

In my case, when I upgraded to Infuse 5, many shows did not have the correct progress indicator. Infuse 4 was correct.

After logging in to the trak web site, I noticed that some shows were correct, some were not. It was not consistent with Infuse 4, but it was with Infuse 5. I had to manually mark the missing shows as watched and Trak updated correctly.

I then watched a show until the end. Infuse marked it as watched but trak was not updated. I had to reset the watched indicator manually (to unwatched and back to watched) and then trak was updated correctly. The fact that Infuse sometimes updates the indicator proves that the trak account info is correct and logged in correctly.

Is it possible the bug only happens when infuse automatically updates the indicator, but not when it is manually updated? It seems that Infuse 4 had the same problem updating the trak progress indicator when it is done automatically.

I only use Infuse on one Apple TV 4.

Denis