Infuse 5 Pro freezing and then crashing. Need help troubleshooting this

I installed Infuse 5 and immediately subscribed to the Pro version. I have the latest version of tvOS installed. Since installing it, I have had several UI lockups where Infuse suddenly stops responding to any remote inputs. After a few seconds or more it’ll crash to the home screen. The error in the diagnostic logs is always the same:

Exception Type: EXC_CRASH (SIGKILL)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY
Termination Reason: Namespace SPRINGBOARD, Code 0x8badf00d Triggered by Thread: 0

After this “Namespace SPRINGBOARD” crash happens, other video apps on the ATV4 become similarly unstable and I have to reboot the ATV4 in order to get Infuse (or Plex or MrMC) to work again.

Any ideas what causes this and how to fix it? Is it a tvOS bug since the behavior spreads outside of Infuse or is Infuse somehow causing the system instability?

Hmm, which version of tvOS are you running?

10.0.1 (14U71)

Do you need the diagnostic logs or do you already have access to them since I have the option to send logs to developers enabled?

This problem is still happening, usually every night. Always the “Namespace SPRINGBOARD” crash. Also, lots of logs generated for “Infuse.wakeups_resource.”

Any ideas if this is an Infuse bug or an tvOS bug? It renders the entire Apple TV unstable.

Is the forum the only way to get support for Infuse 5 Pro? Because I would really like some help to troubleshoot this and to discover the exact cause of these crashes.

What I’ve done so far:

  1. tested on both WiFi and ethernet
  2. reinstalled tvOS and the apps
  3. connected to a different router and modem
  4. removed all other devices from the network
  5. tried another aTV 4

We’re looking into this to see if we can track down what may be going on.

Would you be able to send me a PM with the full crash log (if you still have it)?

I no longer have it on my computer. The thing is, I can’t remember how I got it off the Apple TV 4 in the first place. I used some sort of software, but I can’t remember which one. Any suggestions?

Okay, I figured out how to extract the logs using Xcode. Unfortunately, I somehow triggered the Apple TV to purge all its logs, so I’ll have to wait until the Namespace Springboard crashes occur again. That shouldn’t take long, only a couple of days or so. Then I’ll send you the logs.

PMs sent with two fresh crash logs.

Just an update. The problem occurred again. Infuse couldn’t play any video file that resides on my Mac Mini which is connected directly to my router via ethernet. After Infuse crashed, I tried to play the same video file (and then others) in Plex, MrMC, and VLC. All those apps failed to play the file and some of them crashed. I launched Netflix and YouTube to see if I was able to still stream video from the internet. Both those apps were unaffected and were able to stream video just fine. I then launched the “Computers” app and tried to stream video files from my iTunes Library on my Mac Mini. The videos played just fine. Eventually, as always happens when this problem occurs, the ATV becomes increasingly unstable and one of the video apps locks the entire unit, requiring a forced reboot.

So, iTunes streaming via the Computers app can play my video files without problem, but Infuse, Plex, VLC, and MrMC all fail to play any video once this bug is triggered. The network connection is still up, as is the internet, but these apps specifically are the ones that fail. Do they use a different library or API or protocol to play or stream video files compared to what the Computers app uses to stream from iTunes?