Infuse 5 is now showing updated folders

I recently downloaded Infuse 5 on my apple TV, I stream movies and TV shows from my Airport Extreme disk (connected external HDD)
Today I added a few movies and I tried to play them on Apple TV but I couldn’t find any of them in the library. (though I checked on my mac and they’re clearly there!)
However I tried removing “movies folder” from my favourites, I tried restarting Apple TV, closing Infuse, disconnecting and reconnecting the HDD from the Airport Extreme, nothing worked. The movies are showing on infuse 4 (on apple TV) and on infuse 5 (on iOS) so the problem is clearly from the new apple TV app.

Hope there’s a fix
Thanks for reading!

Were the new folders located inside one of your Favorites, or were they outside? If outside, you would need to add a separate Favorite for these in order for Infuse to see them.

the folders are located inside one of my favourites. Though right now after a couple days and several uses of infuse the changes are showing, guess it just took infuse a while to actually refresh