Infuse 5.7.4 plays Stereo track instead of AC3 5.1 (manually selecting doesn't work)

Hello,

I’m having an issue with Infuse Pro 5.7.4 playing the Stereo track instead of the AC3 5.1 track. On the Apple TV side I’ve tried setting “Video and Audio > Surround Sound” to “Best Quality Available” and “Dolby Digital 5.1” both settings result in stereo being played. I also set my Infuse “Settings > Language > Audio” to “English (United States)” and played with “Settings > Audio Output” and tried “Auto” then “Passthrough”. “Passthough” just plays a loud screeching noise and “Auto” still outputs Stereo. I’ve also manually changed the track while the video is playing to “Track # 2 (English, Dolby Digital)” but that also still yields stereo output. When I play this video via Plex on the Apple TV the AC3 5.1 track plays and works as it should. It’s only via Infuse that I can get nothing more then stereo to output.

Here is some info from ffprobe, and I’ve attached the output of PlexPy showing the video playing with the AC3 5.1 track manually selected.

Duration: 00:42:29.86, start: 0.000000, bitrate: 5531 kb/s
Stream #0:0(eng): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 126 kb/s (default)
Metadata:
creation_time : 2018-06-30T11:04:50.000000Z
handler_name : SoundHandler
Stream #0:1(eng): Video: h264 (High) (avc1 / 0x31637661), yuv420p(tv, bt709), 1920x1080 [SAR 1:1 DAR 16:9], 5013 kb/s, 23.98 fps, 23.98 tbr, 23976 tbn, 47952 tbc (default)
Metadata:
creation_time : 2018-06-30T11:04:50.000000Z
handler_name : VideoHandler
Stream #0:2(eng): Audio: ac3 (ac-3 / 0x332D6361), 48000 Hz, 5.1(side), fltp, 384 kb/s
Metadata:
creation_time : 2018-06-30T11:04:50.000000Z
handler_name : SoundHandler
Side data:
audio service type: main
Stream #0:3(eng): Subtitle: mov_text (tx3g / 0x67337874), 0 kb/s (default)
Metadata:
creation_time : 2018-06-30T11:04:50.000000Z
handler_name : SubtitleHandler

Thanks!

According to the pick you posted the file is Direct Playing. Also looks like you may have 2 audio streams, one AC3 and one stereo on the file. Are you sure you manually chose the AC3 track? Please use mediainfo and post the output. That will show what track is the default.

https://mediaarea.net/en/MediaInfo

Correct, there are 2 audio tracks… Stereo and AC3 5.1. And yes, I manually selected the Dolby Digital track when the video was playing… that PlexPy screenshot was taken with that track selected. Stereo is the default track.

MediaInfo:

Audio #1
ID : 1
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : mp4a-40-2
Duration : 42 min 29 s
Bit rate mode : Constant
Bit rate : 126 kb/s
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 SPF)
Compression mode : Lossy
Stream size : 38.3 MiB (2%)
Language : English
Default : Yes
Alternate group : 1
Encoded date : UTC 2018-06-30 11:04:50
Tagged date : UTC 2018-06-30 11:04:50

Audio #2
ID : 3
Format : AC-3
Format/Info : Audio Coding 3
Codec ID : ac-3
Duration : 42 min 29 s
Bit rate mode : Constant
Bit rate : 384 kb/s
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 kHz
Frame rate : 31.250 FPS (1536 SPF)
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 117 MiB (7%)
Language : English
Service kind : Complete Main
Default : No
Alternate group : 1
Encoded date : UTC 2018-06-30 11:04:50
Tagged date : UTC 2018-06-30 11:04:50

Do you select the AC3 track before you play file, or while its playing? If both, what is the result?

As far as settings, I have my ATV set to “Best Quality” and Infuse set to “Auto” so everything plays as intended, just converts the audio to PCM since most of my files have DTS/DTS-HDaudio. Also, what settings do you have for your Plex server (I assume its local?)?

I actually don’t see a way to change the audio track before playing the video. Is there a way to do that? I’m only able to change it once it’s playing. Since I already changed the track earlier it was already set to Dolby Digital when I fired it back up to test again. Still just stereo. As I mentioned earlier this same video plays fine in the official Apple TV Plex client… AC3 5.1 plays without me having to do anything. This seems specific to Infuse.

I’ve tried the Apple TV settings you mentioned above but the result was still the same… stereo.

I should also mention that Infuse on the pre-play screen for this episode does say it’s “Dolby Digital 5.1”.

What equipment do you have and how is it connected? Everything hardwired?

Can you upload the file and I can test it when I get home?

When you playing a video have you swiped down on your Apple TV remote? and gone to audio then selected the ac3 track. Hope that helps

Edit: ah sorry you have already done that, strange. Is it only on this video or all videos you only get stereo?

Maybe you can edit the video with Mkvtoolnix and delete the aac track and see if that works.

Also are you using tautulli? Maybe update it could be showing the wrong info.

Another thing what does your TV or AVR say when playing the video?

That may be the next best thing to try

Thanks for all the replies. I decided to give this a go on another setup I have in another room. It’s similar to the other room I’ve got… Sony 4k TV, Pioneer receiver and Apple TV 4k. All hardwired via HDMI and ethernet. I still only get Stereo in Infuse but in the Plex client AC3 5.1 (same as the other room). I’ve attached some PlexPy screen caps to compare with. Same Apple TV but one is the Plex client the other Infuse.

I’d say 90% of what I have is mp4’s. As for removing the Stereo track I could do that but I want my mobile devices to be able to direct play when using the standard Plex client.

Thats really strange it does that.

As for your mobile devices, video will still direct play. The audio will be transcoded to stereo by your server. It wont be hard on your CPU since its just audio. Video transcodes will be the kicker lol. However if you could try removing the stereo track on one of your files, that will better determine if the issue really is Infuse or something else. Just for testing purposes.

Yeah really strange that infuse keeps defaulting to the aac track even when you have selected ac3. Just delete the aac track for testing purposes, if even after you have deleted aac and plexpy still shows as aac then there’s definitely something up with plexpy showing the wrong info for infuse.

Btw did you install tautulli? it’s the newer version of plexpy.

I know the latest Infuse release did something with the forced flag for subtitles. I wonder if it affects the forced flag in general, for audio as well?

Yeah but they manually changed the track when playing a video, but his/her plexpy still shows as aac even when they changed it to ac3, which is weird. I reckon they should install tautulli instead of still using plexpy, could be the wrong info being shown when using Plex with infuse.

Have you tested what you are actually hearing through the speakers with the AC3 track selected? I wonder if it may simply be an issue on the Tautulli side where it doesn’t recognize that a different audio track has been selected once playback has started.

Also, on a related note, the logic in Infuse changed recently, so it will auto-select the audio track which is tagged as default (which in your case may be the AAC track). You can avoid this by changing Infuse > Settings > Language > Audio setting from ‘Auto’ to your preferred language. This will allow Infuse to ignore the default tag, and simply choose the best audio track.

Adjusting the setting as described above should allow the AC3 track to be selected from the start, which may allow the status to be reflected correctly in the Tautulli UI.

Yes, it’s definitely 5.1.

Yes, stereo is the default track… I did already make the settings change you mentioned above per another thread I found before creating this one. That change didn’t seem to help in this case.

Yeah, I’m using the latest Tautilli. I never liked the name change so I still call it PlexPy. :slight_smile:

I decided to actually listen to what was coming out of each speaker even though Tautulli was reporting stereo and it sounds like 5.1. Voices are coming out of the center channel etc. Is it possible Tautulli is just reporting it wrong here?

I also created a share from my laptop and served up that video file. Upon listening to each speaker it also sounded like 5.1 was working.

Its possible that Tautulli is reporting it incorrectly. Maybe its reporting wrong due to the default flag on the stereo track? I would try removing the default flag from that audio track and see what Tautulli reports after that.

I typically dont have a stereo track on my files since my server would just transcode the surround audio to stereo when watching on my mobile device so I cant comment if Tautulli reports the incorrect audio track with a default flag on it.

Yeah personally it sounds like tautulli is only reporting the default audio (aac) no matter what audio track is selected.