Infuse (5 & 6) suddenly cannot access files via smb iMac Catalina

After using Infuse Pro 5 for years, with appleTV streaming from iMac1 with Catalina 10.15.4 I suddenly cannot access anymore my folders from my iMac… I see the computer but cannot access the folders. It happened suddenly. So I downloaded infuse 6 and nothing has changed. I do not know what to do. Its completely depressing. I looked in my iMac preferences. File sharing is enabled. However when I look at Full Disk Access I do not see a terminal smbd icon there (I indicate it because I looked through the forum and it might be connected). Please HELP

See if this post in this thread may help shed some light.

Well, I saw this post of you and immediately looked at the Full Disk Access in system prtefs, but saw no icon for terminal smbd… Please see the following screen shot

Did you try disabling file sharing and then turning it back on per the part “disabling File Sharing appears to also disable full disk access for smbd. Re-enabling then re-enables it”?

Thank you for the advise. It did bring back smbd , however, I can still not access the imac and the folder (see picture). When I turn off File Shatring INFUSE Does NOT see the disk, when I turn it on, it sees it but fails to access it. Please help.

See another photo from INFUSE screen

Can you advise me how to test smb file access without infuse?
I do not know how to do it

There are a few things to check.

  1. SMB is enabled on your Mac (more info here https://support.apple.com/en-us/HT204445).
  2. At least one user is selected under ‘Windows File Sharing’ (as shown under ‘Advanced Options’ in the link above).
  3. Selected username and password are being entered in Infuse.

Note: iCloud username/password cannot be used. If you’re using an iCloud ID to log in to your Mac, you will need to set up a new ‘Sharing Only’ user as described here: https://support.apple.com/guide/mac-help/set-up-other-users-mtusr001/mac

Sorry I do not know what to do
I send you now a series of photos that indicate all is fine, but I cannot connect. I reinstalled Catalina… < i tried everything and it just wont connect.
Can you suggest a way to check SMB WITHOUT using infuse?




I’d highly recommend you create a new user your ATV and give it read only access and make sure that user is checked in the SMB sharing box. I’m guessing the name you are showing is your admin account for the iMac? If so, I’d for sure create a new user account for streaming and limit it to read only.

I’m not familure with Catalina but one other thing, when you do a “Get Info” on the drive that your files are on you want to see if the “Shared Folder” box is checked in earlier versions like Mojave

Hello
I did as you suggested, opened a new user ATV, gave it the permissions as suggested, but it is still not connecting…
I am lost
Thanks
Eilam

Can you try using the short username for your Mac instead of the full name? This can help in some cases.

Your short username should be the same as the name of your home folder.

Another option to try is to use the IP address of the Mac instead of the shared name.

Better to start with the short name as James was saying since using the IP would just about require a fixed static address to be assigned and to get the OP started the short user name is easiest.

I think James was talking about the username, not the server location. Anyways yes use the server name first, but if it doesn’t work, try IP address

Hello
Thanks for answering
I am not sure what do you refer to as user name and ip address
Is ATV not short enough or is it not the user name you refer to?
Also whta do you mean IP address and where and I do I implement it
Do you mean smb://10.100.102.5
or what?

username is the name of the account on the computer. This usually has two versions. A short and a long. Looks like the long one is “Eilam Gross”. The short version of this would be something maybe like “eilamgross”.

Yes the IP address would be something like 10.100.102.5 but only use that if you have locked/fixed it based on computer MAC address.

1 Like

Hello
I have spent some time with experts from my workplace (university)
We checked together
Indeed my username is eilamgross
If I go to any webbrowser within my net and type. smb://eilamgross-s-imac1.local
and use the user eilamgross with my password i easily connect to my folders on imac1…
So the problem is within INFUSE
It sees the imac1(SMB) but fails to connect…
I am lost with ideas…
I tried everything went to the biggest experts.
I can connect with SMB to my mac from everywhere on my bet except with INFUSE
Please tell me ewhat other info I can deliver to you
In addition, following another thread here, I removed all VPN detected software I could find on my computer, nothing helped. I really need your help.
Have you made any update to INFUSE recently?
eilam

As a quick test, can you try changing the SMB version in the Advanced section of the share settings to SMB2 or Legacy?

If that doesn’t help, please send a report via the Settings > Submit Diagnostics option in Infuse and post the 5 digit code it gives you here.