Infuse 3 Pro: Airplay not working

I just upgraded to Infuse 3 Pro on my iPad3 with iOS 8.1. I can’t get Airplay to work. When I tap the Airplay button, only my iPad (where Infuse runs on) is shown. In other apps my AppleTV is visible and can be selected for Airplay. I tried several movies which played via Airplay in the previous version of Infuse.

What’s wrong?

See screenshots from my iPad.
First is Infuse, no Airplay option for AppleTV
Second is iPad, Airplay option for AppleTV available
Third is QFile app, Airplay option available for AppleTV

I also tried restarting my iPad and uninstalling/re-installing Infuse. Did not help.

It looks like Infuse is the only app without Airplay option for AppleTV?

There is AirPlay, just for some reason on iPad, the menu doesn’t render properly.

If you use your finger, you will find that the popup box is actually scrollable and your AppleTV will be listed after it.

I think this is an iOS thing rather than an Infuse issue.

You’re right, it’s scrollable! Problem solved. Thank you!

Yep, this is definitely and iOS 8(.1) issue, as the same weirdly formatted AirPlay box can be found in the native Videos app.

Hopefully this will get sorted out soon.

Hello - I use Infuse 3 pro, have an IPad 2 - AirPlay is only possibles with screen copy (mirroring) on apple Tv is that normal? Thx!