Infuse 2 and NAS (WD My Net N900 Central)

Hi Guys

Anyone else experiencing problems
with the WD My Net N900 Central?

Logged a ticket but not received a response yet (#49866)

It finds it in the available shares,I then input my username and password It connects to the root folder which on my device is called public

I click on the folder and it loads my initial file structure

Then I click on my films folder (this is where it goes wrong)

It loads another public folder then I try and click on that public folder it loads another public folder and so on repeating opening public folders.

My Structure is as follows

Public>Films>(actual film) Public>TV Shows>(Show)>(Season)>(actual tv show)

The Stucture Infuse Shows is Public>Films>Public>Public>Public>Public>Public>Public>Public>Public> Recurring!!!! on any folder and no video files

 

[[wysiwyg_imageupload:432:]]

[[wysiwyg_imageupload:436:]][[wysiwyg_imageupload:434:]][[wysiwyg_imageupload:437:]]

[[wysiwyg_imageupload:438:]]

Are you using a username and password to connect? Based on the fact only the Public folder is accessible, it sounds like Infuse is connecting as a guest (which will happen if no login details are entered) and guest access is disabled on your NAS.

Yeah entering username and password,
If I don’t enter one and leave it blank it doesn’t connect it comes up with an error occurred which Is what I’d expect

I’ve even tried taking the password off my nas and tried connecting to it that way and still does the same with the recurring public folder

I have the same issue with my WD N750. And it seems to be it’s identical to the one we have with Infuse for AppleTV. It has something to do with the implemented SMB protocol. There must be an incompatibility between the WD routers and Infuse. No solution yet although I was hoping that this was resolved with Infuse 2 for iOS but it looks like I’m out of luck…

Here’s the ATV2 topic: http://forum.firecore.com/topic/10653