Infuse 2.0 can't play mkv files

Hi,

Why the infuse 2.0 can not play mkv format? I have purchased the premium version and still can’t play mkv files.
The mkv format is 1280 x 720 h264 version.

Regards,
Erwin

I have no problems playing mkv files.   You probably need to provide more information about the mkv files you are having issues with.

One limitation that is there is that at the  moment mkv files with embedded DTS sound tracks cannot play the sound.   I believe this is due to be fixed in a future release once licensing issues for the codec have been sorted out.

Dear itimpi,

The mkv format was mentioned earlier: 1280 x 720 h264. It didn’t show any images at all. It only show the “loading” icon and the time keep jumping/skipping.
If it doesn’t support the format, at least the program should have checked and mentioned earlier before I purchased the premium version.
FYI, After that, downloaded other free program and can play my mkv perfectly without any issue.

I play plenty of mkv files that have that resolution without any issue.   There must be something unusual about the ones that you are trying that inFuse does not like.  By more information I was meaning the sort of detail that a program like mediainfo supplies.

It sounds like these may be Hi10 MKV files, which are currently not supported.

Limited support is coming in version 2.2, but will likely only be available on the faster (A6/A7 based) devices.

I have the exact same issue except I cannot play any file types - AVI, MKV, MP4, I have tried over 160 movies / shows from a variety of different sources and I always get the exact same error (see attached) - Its weird too because all other video players in the App Store (even the free ones) play my files perfectly. Infuse is honestly the most frustrating app I’ve ever had the pleasure of spending 5 dollars on and I expected much more from the makers of seas0npass =/ Very misleading in their marketing as well, it should be made more clear in the product description that infuse is currently a work in progress and only capable of playing a very specific sub-type of mkv. I have attached a detailed log of the video files I am speaking of having difficulties with specifically… I hope the devs will actually look into things as apparently this issue effects a number of users.

Have you tried transferring the file onto the device to play rather than trying to play it via streaming over the network? This would help identify if inFuse simply cannot play the file because of its format, or if it is related to the new ability to stream files.

I am hoping that it is only in streaming mode there is an issue as that might help explain why some people seem to be able to play files OK while others do not. It might be related to what devices are holding the files and how the network/shares are set up.

I agree with itimpi, it sounds like it may be more of a streaming issue than a file format issue.

What type of device are you streaming from, and are you using a username and password to connect?

I have tried with and without a username and password and got the same results. The specific model # of the NAS I am using is an Iomega Home Media (Cloud Edition) 1TB. It is using standard SAMBA fs protocol. I will try transfering a file to the iPad in a bit and let you know how it turns out.

Transfered an episode of TV to the iPad and it played when it was stored locally. Im just flabergasted how it would really be my NAS though as its just using regular smb, plus the 10+ other video apps and numerous other devices I have in the home are all able to playback from it without issue.

It is good to know that it is not the file contents that is the issue, but something related to streaming. This at least explains why you see an error where others do not.

Identifying the problem as being related to streaming does not prove that there is not an issue inside inFuse to with handling the network. Unfortunately there does not seem to be much in the way of diagnostics you can get out of inFuse. It would be nice if some sort of logging facility was introduced (accessed via settings) to help with resolving such issues. Having said that you might be able to find something you can change at the networking level that bypasses your current problems.

 

I Have the same NAS and the same issue…

Stream does not work here.

 

This actually has something to do with the Iomega Home Media (Cloud Edition) NAS drives. If you have an external USB drive connected to it, Infuse can stream from that without any issue, so for whatever reason the issue is limited to the internal drive only.

We’re looking into this, and hope to have a fix in the 2.2 update (which will also include an updated SMB core).

Just downloaded Infuse Plus on iPad assuming Infuse would also play VIDEO_TS (IFO VOB) files. This is the main collection video formats I have. It works fine in Infuse on ATVFlash. However, Infuse Plus does not recognise the files on iPad or iPhone.

Is that correct? Any suggestions how to cope this problem?

THX

BTW: the same for ISO files

Neither of these is currently supported (neither is on the list of formats mentioned in the App Store description).

Having said that from what James has said I believe that bpth of these are on the roadmap for future releases.   I personally would certainly like support for both of these added.

Thanks for the confirmation (I read it after buying Infuse Plus). As Infuse on ATVFlash handles these formats I thought Infuse on iPad/iPhone would do that as well. I hope, like many others, this will be the case with the next release!