Infuse 2.0 - AirPlay Surround 5.1 not working

Hi everbody,

I have Problem with Surround Sound via AirPlay using Infuse 2.0.

My Hardware:

iPhone 5 - iOS 7.0.4

Apple TV 3 - iOS 6.0.1 (Setting “Dolby Digital” is set to “on”)

Apple TV 2 - iOS 4.4.4 - Jailbroken using aTV Flash 2.3 (Setting “Dolby Digital” is set to “on”)

Pioneer AVR with 5.1 Speakers

I downloaded a Dolby “Channel Check mp4 large” file to test the AirPlay surround feature:

Dolby Test Files

But it doesn’t work from the iPhone to neither of the ATVs in surround - only stereo. What does work is: To play it from atv2 with atvflash infuse player in surround 5.1 perfectly. So I think it’s an AirPlay issue and not an issue of my surround system. Here’s what the file in the app looks like: [[wysiwyg_imageupload:428:]]

 

Hope you have an Idea or maybe this is already a common bug?!

Or could anyone of you please try to play this file? Or does it work for anyone of you in general?

Can you double-check and ensure that Dolby Digital over AirPlay is enabled in the audio playback settings?

This screen can be accessed by tapping the gear icon while a video is playing.

[[wysiwyg_imageupload:429:]]

Hi, thanks for your reply!

I tried several test-files now and I found out that it actually works with some files!

But not with the mentioned file! The Audio Track description says “5.1, Dolby Digital Plus, 01:21” but there is no option for “Dolby Digital over AirPlay”. Obviously the given Audio Track is not supported.

Could you please clarify which Audio Tracks are supported for “Dolby Digital over AirPlay”? Obviously not all Dolby Digtal Tracks work.

So, all Dolby Digital tracks will be supported over AirPlay. These are typically 5.1ch 16-bit audio tracks.

Dolby Digital Plus tracks are typically 7.1ch 24-bit audio tracks, which are supported when playing on the iPad, but since the Apple TV is limited to 16-bit audio output these tracks cannot be streamed over AirPlay without Infuse first converting them to something the Apple TV recognizes.

I hope that helps clear things up.

I am having the same issue with all of my 5.1 Dolby digital not playing to airplay in 5.1. There is no option to enable dd over airplay.

My issue is the same as above, however, I see the dolby digital over airplay switch, but it's grayed out/disabled...

 

 

[quote="Noahkaoi"]

My issue is the same as above, however, I see the dolby digital over airplay switch, but it's grayed out/disabled...

 

 

[/quote]

did you update to the latest ios..that seems to solve the problems i had

Yes, I have upgraded to iOS 7.1. It's still not working...same behavior. :-(