"Indexing failed" on Mac and ATV but not iOS? How?

I use Infuse on my Mac Mini and my Apple TV 4K. My files are located on an external SSD connected to my Mac Mini, and I use an SMB share. Everything’s been working fine until tonight. Last night, my wife and I were watching a show on the ATV upstairs and had to stop in the middle of it. When we went to resume it this evening, I suddenly got “an error occurred loading this content”. When attempting to scan for changes in the library on the ATV, it said “Indexing failed” for SMB.

So I went downstairs and attempted to play a few different things on Infuse on my Mac, with the same results. I restarted the computer, and even updated to the latest version of Infuse that just came out today (7.5.3), and no change. Indexing failed. Although if I go to any of my movies/tv shows in Finder and “open with” Infuse, the content loads and plays just fine.

So then I open Infuse on my iPhone (which I never use to watch content, but have it there “just in case”). And lo and behold, it indexes just fine and lets me watch everything without issue.

I don’t understand why Infuse on iOS is encountering no issues, while both my Mac and my ATV can’t seem to index properly so I can watch on those devices, especially when it was working just fine last night and nothing has changed since then. I don’t know where to begin to try to resolve this.

First thing is to make sure you have the same version of Infuse on all devices. Also, check the sharing settings on the Mac, with the recent security updates and OS changes it may have reset some of your preferences. It never hurts to restart the Mac too if you haven’t yet.

My Mac is now updated to the latest (7.5.3), although it was having the issue both prior to the update and after.

The version on my ATV was already 7.5.3 due to automatic updates.

While checking to see what version was on my iPhone, I saw there was an update that just came out today, so I updated the iOS app (also to 7.5.3). After updating, suddenly the iOS app, which was the only one that was working, also started reporting “indexing failed”.

I restarted my gateway/router and computer, with no change. I checked the sharing settings on my Mac and nothing looked out of place there (File Sharing was turned on, all the appropriate folders were listed there that I was sharing from before).

Then I had the bright idea to check the “Get Info” for each of those folders in Finder, and realized that the checkbox next to “Shared Folder” was, in fact, not checked. After checking that on all of the relevant folders, both my iOS app and ATV finally started indexing properly, but my Mac was still failing. Once my iPhone and ATV finished indexing, I gave the Mac a quick reboot, and now everything appears to be back to normal.

Still not sure why one device was initially working when the others weren’t, if the sharing settings on my Mac were the issue. Nor am I sure how the “shared folder” checkboxes got unchecked as I haven’t done any OS updates (still on Ventura 13.0) or messed with settings at all.

But regardless of the reason, thank you for your advice! I was starting to get really frustrated.


Well, I spoke too soon.

As of this morning, Infuse was still working on my Mac Mini (which for the record is always on, never sleeps), and on my iPhone. But not on my Apple TV.

I should clarify that I actually have 2 ATVs (the downstairs one doesn’t get used much) … both have Infuse on 7.5.3, so all of my devices are on the most current version. Indexing was working on our downstairs ATV last night after my “shared folder” checkbox fix (couldn’t test the upstairs one at that time as my wife and 4yo son were asleep while I was working on this). So I expected that this morning when I tested the upstairs ATV, it would be fixed like the downstairs one. When it was still indicating “Indexing failed” on the SMB, I checked the downstairs one and it too was failing again. Mac and iPhone indexed fine. I restarted the downstairs ATV, but no change. I didn’t have time to restart the upstairs one as I had to get to work.

Now that I’m at work, I tried scanning for changes on my iPhone while on WiFi and got indexing failed. Then tried on cellular and still got indexing failed. I’ve never tried to access Infuse outside of my home network before so I’m not sure if that’s normal or not for my use case.

We’re getting ready to leave on a trip for the weekend so I don’t know how much time I’ll have to toy with this until we get back. I’d been holding off on updating my macOS (currently 13.0) due to known issues with SMB sharing in 13.1 or 13.2. But supposedly that’s been fixed in 13.3 (though I’ve seen reports that some are still experiencing issues), so maybe I’ll have to try updating and/or the whole turning file sharing off > rebooting > turning file sharing back on trick and see if any of that helps. As a last resort, I may have to try removing the SMB share entirely from all devices and setting it up like new again on each (I really hope I don’t have to though, it’s such a hassle).

I guess I will update here once I’ve been successful or have exhausted my options.

1 Like

Okay, I think I’ve got it fixed, finally.

I started by upgrading to 13.3.1 (along with some security update afterward), but that didn’t change anything. Indexing still failed on all devices.

In the file sharing system settings, I removed the folders I was sharing from the list and turned file sharing off, then rebooted, turned file sharing back on, and added the folders back to the list. No dice, indexing still failed on all devices.

So I was resigned to deleting the SMB share I’d created and been using up until now and then setting it up all over again on each device. I started with one of the ATVs, removed the share, then restarted the device. When I went to add a new SMB share, that’s when I noticed that an existing option, which I don’t recall seeing before, was already listed as a share to add, simply titled “Mac mini”. I plugged in my username/password, and voila … indexing!

When I originally set up the SMB share that I had been using, I used the address shown when you click the little “i” next to the file sharing toggle in sharing settings, {name}.attlocal.net. This new “Mac mini” SMB share, however, appears to just be using the general local host address, {name}.local (found at the bottom of the sharing settings pane).

I repeated the process on my other devices and all indexed properly and played content without issue, including proper syncing with iCloud.

I don’t know why the SMB share I’d been using successfully up until now just suddenly stopped working, or if this new share had always been there and I just didn’t notice and made things more difficult than they needed to be by creating a different share, but for the moment, all devices are working again. I’ll give it a few days to see if the indexing issue crops up again, but for now I’ll consider this resolved.

1 Like

One thing we have observed with certain dual-band routers, is some devices will be available on one band but not another (2.4GHz vs 5GHz). I personally have an AirPort Time Capsule that exhibits this issue.

Not sure this phenomenon is the cause here, but since Apple devices will automatically switch between these bands it could explain why it works sometimes but not others.

What some people have done to work around this is create separate networks for each band, and then connect their devices to one or the other. Just something to consider if this issue appears again.

1 Like

Thanks for the tip. I’ve got AT&T Fiber, and their gateways (ONT & router combo) are dual-band, but as far as I can tell, they don’t allow you to create separate networks for each band. If a device can connect to either 2.4 or 5GHz, it just automatically connects it to the band it deems the best fit. One of the downsides of not being able to use your own router, unfortunately (technically you can set one up as a passthrough, but it’s a bit more involved than I feel comfortable with).

In any event, I don’t think that was the issue, since this is the first time I’ve experienced this problem and I’d been using the original share for months (plus my Mac was exhibiting the problem as well and it’s connected via ethernet … as well as directly attached to the SSD where the files are hosted), but I’ll keep it in mind. Hopefully this is a permanent fix.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.