Indexing failed ! NAS Synology !

I’ve seens multiple posts about indexing failures but none that seems to provide a consistent fix or solution to the problem.

I have a number of Apple TV4’s that all have the same problem. Indexing fails.

Initially it did not fail. But it only worked once on the first installation ! And have never caught up with never files.

The connection is Wired to a router where a Synolgy DS415play is connected. The Synology runs Plex and exposes the directory using uPnP/DLNA.

I can see the Plex directories from Infuse 5.5 and have tried removing and reconnecting Infuse to the share. Same Error. Have removed the metadata. Same error - indexing fails. Have rebooted everything. Router, NAS, Apple TV. Indexing fails.

Have even tried connecting Infuse to a SMB share where the Plex library is two levels down. Does not seems to be able to index as well. I can browse the files which are not on the root level of the share but a couple of levels down.

Also. How annoying is it that with 4 apple TV’s they all independently have to index the shares ? So they all need to do it individually which is a pain. Yes the meta data takes up space. But give us an option to sync them via icloud.

Indexing fails.

Have you tried cutting out Plex and just adding the folders on your Synology directly? I had issues with Plex’s DLNA server a while ago similar to yours and just removing Plex from the equation made it much simpler (and 1000x faster).

Yes the problem is not your Synology NAS.

As suggested above, try connecting directly to the Samba server of your NAS, setting in Infuse only the Shares you want to synch.
It works flawlessly and indexing is quite quick (and doesn’t fail)

Tried to add the volume as an SMB share and set the plex library as a favorite.

Can browse the files manually. But when going into the infuse settings and “scan for changes” it does nothing ! (2800 files and folders).

It tells me that there are no files at all ? Even though i can browse the folder and play them manually. But no indexing takes place !

The i tried adding the share as a uPNP/DLNA share. Again i can browse the files. But when i go into settings and try to enable the “library” and “scan for changes” nothing happens !

Any pointers ?

Again with both SMB and uPNP/DLNA manual browsing works but the library does not index anything !

After adding the share via SMB you’ll want to add at least one folder as a Favorite. This should be a Favorite added while browsing the saved SMB share, as adding a Plex based favorite will simply use the original Plex connection and not the newly created SMB one. A reasonable option might be to remove the Plex and other UPnP/DLNA shares from Infuse entirely, just to be sure you’re only using SMB.

Once a Favorite has been added, you can check Settings > Library to monitor current fetching progress.

1 Like
  1. Add share via SMB - DONE (multiple times … DONE) !
  2. Add the plex library folder (where the movies and tv shows are) as a favorite - DONE (multiple times … DONE) !
  3. Remove all other network mappings (like uPNP, DLNA). - DONE (multiple times … DONE) !
  4. Go to settings libray and check indexing - DONE (multiple times … DONE) !

Same result ! first times kinda works. Either Movies or TV shows seems to be indexed but not both. And then “indexing failed” forever !

Now i tried the following !

  1. Remove all shares
  2. Disable icloud sync
  3. Connect via NFS
  4. Mark the plex library as favorite !
  5. Go back to the main page and browse the files in the “library” … Works ! (just like it worked with SMB). When i click on an item it grabs the metadata correctly (as it has always done).
  6. Go to settings - Library - Scan for changes ! … NOTHING ! Stops after 2 seconds.
  7. Reboot apple tv. Start Infuse -> go to settings -> Library -> Scan for changes … NOTHING! Stops after about 2 seconds.
  8. Go back and manually browse the library via Infuse … No problem !

Now, with NFS it does not scan/index at all !

Manually entering the favorited library works ! But scan and indexing does not. Over and over again !

Did exactly the same for the SMB share (removing the NFS share first). And i can do the first scan (only discovering tv shows though) ! And then i went manually into the favorited library and browsed files. Tons of movies that were all recognized correctly.
Went back to setting library to see if a scan for change would discover the movies. And after scanning all counters went to 0 ! So all metadata was lost ! What the heck ???

OH, BTW. Connectivity have been tested by both my Mac and by manually going to the library (the favorited folder) using infuse !

What’s going on ?

Are you favoriting each media folder individually or just the media folder? You should have your movies in a ‘Movie’ folder that is a favorite, and then your tv shows in a ‘TV Show’ folder that is a separate favorite.

Everything is stuck in the same main folder where some tv shows and movies are in separate folders and others are not !

I’m “guessing” that the same detection engine is used for both movies and tv shows since when you mount there is no specific mention of one or the other. And it does work with Plex and others. And also worked at the very first installation of infuse i did !

Still. Pointing to a folder does not solve the indexing failed issue !

Things have been “kinda” working for the past 12 hours now! With icloud sync enabled.

If i start infuse and wait for a bit. Then click in the favourited folder manually and enter it and WAIT for a bit (takes about 2 minutes to show the folder). Then I can go back to the library and view the movies and the detected tv shows and play everything. And that has shown to be a relatively stable method for on 2 different apple TV’s.

It may look like a timeout issue. I wonder if Infuse mounts the favourited directories immediately when you start the app. And it may time out more quickly than what it takes to mount and cache the entries in the massive folder that I have !

BTW: It’s truly insane that you cannot sync metadata between multiple installations of Infuse so they each have to go through the motions of grabbing metadata for everything !