"Indexing failed for..."

Hello,

So, indexing doesn’t work anymore on Atv 4K. I have to fetch new content from the iPad, start the reading and stop it, sync it with iCloud, and only then the new content appears on Atv.

They are both on the same network, I’ve never change anything on it (same user, same password from the beginning of time).

What should I do to have it work again?

Source is Sinology NAS with a share in SMB mode.

I know that occasionally, I get that from my Synology but if i just click on “Scan For Changes” after that it will scan the NAS.

Sometimes if the server doesn’t respond fast enough Infuse will give you that error.

My Synology is set to sleep so occasionally it gets woke up and has to spin up everything to answer. :wink: Even if your NAS isn’t set to sleep it does have maintenance tasks that if you catch it just right it has to finish the task before it can respond to the request and that may be happening too.

Hi,

It has nothing to do with my NAS. It doesn’t sleep, tasks are scheduled during the night, and more to the point:

I actually once tested the scan for changes at the same time on the iPad and the atv. On the iPad, the changes were detected almost immediately, when the atv returned the error. If it were the NAS, both devices would have returned the error message.

As I said, it’s been awhile now that if I don’t do the steps I wrote in the first message, the atv doesn’t fetch new data.

Regards

So if you get the error on the ATV then hit the scan for changes it errors again? What about hitting Scan For Changes a third time? I know it sounds like a waste of time but I’ve personally experienced this and had it take an extra scan. Just trying to eliminate things.

How is the ATV connected to the network? What protocol SMB, FTP, etc?

Is the ATV primary user the one you’re using for Infuse?

In the share settings what do you have for the NAS address? numerical like 168.1.1 or the alpha name like nas.local?

I know you said it’s not the NAS but you may want to check since I believe that Synology just had an update and it’s been known to happen occasionally where settings have reverted to original.

Have you tried a restart on the ATV?

Helllo,

Sorry for the late answer. It actually worked for a couple of days, but problem’s back. I didn’t do anything to have it work again.

My answers to your questions:

Tried it more than thrice. Doesn’t change anything.

SMB via LAN.

Yep.

The latest update had to be installed manually, since they suppressed support for the AAC codec. The problem appeared way before the update anyway.

More than a few times

So, yesterday, I added 4 tv episodes. Launched Scan for Changes on iPad, they were detected immediately. With a simple iCloud refresh, they also showed on Infuse for Mac. The ATV is still looking for changes as I write this. Granted, the ATV was off these past 16 hours. And it seems the iCloud connection is either very slow or not working. Yes, iCloud syncing is active on ALL my devices.

Best regards

PS: just added 3 more episodes. They instantly showed on my Mac once I clicked on the reload arrow on the top right corner. Didn’t even have to click on Scan for Changes. If I’m being candid, that’s the behaviour I’m expecting on the ATV.

Ethernet or WiFi?

Ethernet.

Updated ATV system after I wrote the last message.

The added episodes mentioned earlier are now available and the iCloud syncing is also done.

Didn’t change a thing on the NAS. Hope you can figure it out coz it’s a mystery on my side.

I do love a good mystery… when I’m not the main character. :sweat_smile:

Bump this!

i have the same issue without changing anything.
I use INFUSE on multiple devices (iPhone, MAC, AppleTV) with a Synology NAS as Mediaserver and connecting via SMB when i am in my local network (works all fine) or via webDAV when i am away.

On my 2nd AppleTV 4K which is set in our holliday home i get the ‘indexing failed’ error mesage when trying to update the Library or starting a movie, i can see the shares but after a view minutes in a stream or indexing i got that error message.

it worked for years and suddenly i got that error.
i changed nothing on a the setup.

i tried everything: Reset AppleTV, Reset Router, deleted all shares, deleted app on all devices (deletetd data on iCloud), set up all new, set up new user on NAS, checked all settings on NAS, checked all settings on router again and again, changed protocol from webDAV to FTP.

1 Like

I get same error too. This problem appear since the last update.

If you’re able to submit a log from your device (and post the 5 digit code here) we can look further into what may be going on here.

1 Like

For me my code is WW8RM
I got the error twice. the list was not updating to the home page when I added a new file. When I went to the settings it told me that an error had appeared. On the other hand I could see it if I went through the favorites by opening the folder the file was present. I had to press the refresh button several times before it updated showing the new file added.
(Sorry for my bad English)

It looks like Infuse is not able to locate the NAS on the network.

This may be because the NAS issue offline, or the sharing settings have changed.

Another potential cause is due to the fact the Apple TV will automatically switch between network bands (2.4 GHz and 5GHz) if you have a dual band router. We’ve seen some cases where a device may be available on one band but not the other, so this may explain why the NAS is available sometimes.

One thing you can try to workaround this would be to create separate networks for each band (if your router allows for this). This will allow you to see if you are being affected by this issue.

I ran into the same issue on my AppleTV. It’s like my Synology is going to sleep, as I have to restart everything to temporarily solve the issue. I made sure all sleep/battery saver preferences on my synology are off. I started running into this issue about the same time as you, were you able to find a solution?

1 Like

my code is G18Q7

jellyfin 10.8.13 (ethernet). all devices, regardless if eth or wifi, returns indexing error.

how can we view the log generated (in the above code)? i would like to know what is written to logs.

nevermind. i checked logs on the server and i saw this error:

Error processing request: “[192.168.x.x] User is at their maximum number of sessions”.

I increased Maximum number of simultaneous user sessions for the user and indexing functions. my bad for not checking server logs first. heh.

1 Like