Incorrect type with embed metadata

Found a bug, where files that using embed metadata (from xml file) shows in “other” type category and i cant find a way to move it to the movies or tv shows. All the data in xml copied from imdb and displayed correctly in the app on tv/mac/iphone. Only its file type always recognises wrong.

Who else faced this issue? What can i try to resolve it by myself?

Welcome to the forum!

Just to make sure I understand what you have, have you actually embedded the xml data into the video file or are you placing a XML file in the same directory as the video?

Video + XML = 1 folder. In infuse “video_name.xml” selected as source

You may want to try changing the file name from “Beyond Two Souls.mkv” to “Beyond Two Souls 2013.mkv” and change the xml file name the same way. Adding the year should let Infuse know that it’s a movie. The same for TV shows, make sure you have the season and episode number on both the video and the xml file names. Like “Clarice S01E01.mkv” and “Clarice S01E01.xml”

This may help if you haven’t seen the users guide before.

Did not worked. Also, cant add the big background image for infuse 7 :frowning:


Снимок экрана 2021-05-07 в 17.32.11

Did you try adding the year to the fanart name?

You may have to do an edit metadata on that video for Infuse to pick up the changes.

Also I just noticed that in the xml file you have “Media Type” as “Video Game”

Try “Movie”

Wow! Thanks, that really helped. But i still cant add a fanart to this movies. Tried with/without year in the name & different names (all options from 101 guide). Is it even possible to add fanart to a movie? Because on tv shows that works fine as i can see.

Yup, it’s possible. You may want to look at that users guide I referenced above and look at the naming formats including spaces and dashes in the example near the top of the guide for the example movies “Inception” and “Pulp Fiction”.

See if that gets you closer.

Yeeeeeey! Finally! This was so unclear for me, that i have to follow the rules SO STRICT. Added [ - ] before [ fanart ] and that worked. Thats so much, mate! :slight_smile:

1 Like

You’re welcome! I know it seems so strict but you get used to the little quirks for file names and it becomes habit. Glad you got it working!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.