Incorrect Metadata for Media Player 0.9.4

After updating to Media Player 0.9.4, suddenly Metadata for Doctor Who (the new series) appears incorrectly. It’s pulling metadata from the old Doctor Who episodes.

My folder is correctly named “Doctor Who (2005)” as per the TVDB recommendation. However the individual episode names are simply “Doctor Who - Episode name”

In the previous version (the one bundled w/ ATV Flash RC1 which came out a few weeks ago) it worked correctly, as well as working correctly with XBMC.

Have you tried reloading metadata for the incorrect items? Highlight the incorrect item, hold select, and choose the Reload Metadata option.

This will allow you to choose the correct series from a list.

I went and reloaded the metadata for the episodes I have. Now instead of pulling the wrong metadata, it just doesn’t pull any. I guess that’s an improvement, but it still doesn’t work. Not like it did in the previous version.

Also it’s a bit of a pain to do this for each individual file. Is there any way to clear the metadata cache for a whole folder?

 

Thanks.

After further experimenting, I’ve noticed that NONE of the metadata for any shows are pulling correctly now, not just Doctor Who.

Nothing changed w/ the NAS directory structure, so I’m not sure why this is happening. :frowning:

Have you checked that the folders holding TV shows are correctly set as that (they may be set as ones for Movies). This setting is mportant a it affects where Eia Player goes to look for metadata. Select a folder and hold down the OK button on the remote to bring up the menu that allows this to be checked/changed. As this setting seems to be inherited by sub-folders you can do it at the top level of the folders contains TV shows.

Yes, I have ensured that they are set to TV Shows and not Movies.

Last night the metadata for everything besides Doctor Who started working again, so whatever it was was probably just a fluke.

Doctor Who is all still wrong though. If I leave everything alone it labels every episode I have as “Snackdance” (http://tardis.wikia.com/wiki/Snakedance) which was some episode from the 80s (20th season). If I manually set the metadat source to “Doctor Who (2005)” or “Doctor Who (2009)” as described by James, it just shows the generic show description and can’t pull the title for any episode. :frowning:

Does anyone else here watch Doctor Who (the new ones), and if so, how do you name yours? Maybe I’m just naming mine wrong. My names are set up like this: /TV/Doctor Who (2005)/Season 6/Doctor Who (2005) - 06x04 - The Doctor’s Wife.mkv

For what it’s worth, XBMC is completely fine with this filename as a metadata source.

 

Dunno about XBMC as I don’t use it, but the rest is spot-on… My files were named doctor.who.2005.1x01 space episodename and I had the exact same problem. The solution was to rename them to doctor.who.2005.S01E01 and after that mediaplayer correctly recognized all episodes. Dunno why exactly, as I have more series which need a year (eg. Castle.2009) in the filename to work, but I guess there aren’t that many series that actually have 20 seasons or more. Still, it’s annoying, but solvable.

I can confirm that this fixed it on my end too. I played around with “Doctor Who (2005)” and “Doctor Who 2005”, but that didn’t matter. The problem was naming my episodes 06x01 instead of S06E01. Weird, because literally every other show I have uses the 01x01 type syntax. Who knows.

BTW  AJvK, I found out that the “Specials” are Season 0 and each especial is the episode number. For example, last year’s 2010 Christmas special is S00E34. Just in case you had problems with this like I did.

I hadn’t started naming the special episodes yet -I was just glad I had the normal seasons/episodes working- but I confess I don’t quite understand what you mean.

I have several (Xmas) specials:
1 each for 2005 (Christmas Invasion I think), 2006 (Runaway Bride), 2008 (The Next Doctor) and 2010 (Christmas Carol), 2 for 2007 (Time Crash an Voyage of the Damned), and 4 for 2009 (Planet of the Dead, The End of Time 1 and 2, and the Waters of Mars). How should I numbers these exactly? I’ve looked at epguides.com but I can’t figure out what the episode numbers are supposed to be…

TheTVDB will list Specials in their own separate list (E.G. http://thetvdb.com/?tab=season&seriesid=78804&seasonid=26260&lid=7)

That ‘season’ list should be an accurate guide for how to name special episodes.

‘Christmas Invasion’ would be Season 0 Episode 2.

james, any hope this could be filed as a bug report so that it might get fixed in a future version, so I don’t have to manually rename all my Doctor Who episodes? (Because I’m incredibly lazy!)

Great! Thanks James, I did not know that website - here’s to another weapon in my arsenal for correct metadata.

Are you including the specials as part of the normal seasons now?

Based on the way specials are organized by the TheTVDB, I’m not sure if it’s possible to name them any other way.

If you click on one of the special episode details from season 1, season 2, etc… shows the episode # based on the specials list, not the actual season. E.G. Clicking “Special Mini Adventure (Children in Need)” from the list at http://thetvdb.com/?tab=season&seriesid=78804&seasonid=15688&lid=7 shows this as episode 1, which of course refers to the first special episode, and not the first episode of season 1.

Nevertheless, I’ll pass along the info and see what we can do.

No problem. TheTVDB is what we’re currently using in Media Player for TV Show metadata, so that site will give you the most accurate info for TV Shows on the AppleTV.

No, I keep everything in a separate subdirectory:

/TV/Doctor Who (2005)/Season 4/Doctor Who (2005) - 00x00 - blahblah.ext
/TV/Doctor Who (2005)/Season 5/Doctor Who (2005) - 00x00 - blahblah.ext
/TV/Doctor Who (2005)/Specials/Doctor Who (2005) - S00E34 - blahblah.ext

I don’t mind renaming the specials, but it’d be great if all the other episodes worked w/ the standard 00x00 syntax for every other show.

(Still, now that I know a solution it really isn’t that bad.)

Thanks for the support. I appreciate it!