Imported TV Shows don't show up in TV Shows Menu

I have synced a bunch of tv shots to the external drive that I have attached to my Apple TV. All the shows can be seen and watched through the Nito TV menu.

When I go into Sapphire, I click on ‘Import All Data’. It does what it does and finds all the shows and asks me the questions regarding the IMDB and all is good.

But when I now go into the TV Shows menu, none of the new shows are there. Neither in the unwatched menu or the all shows menu.

Any ideas on how I can get them to be displayed?

I only installed Sapphire 2 weeks ago so I assume it is the latest version, and up until 2 days ago it was working as it should be.

I’m having the same problem - all was well until a few days ago, but now I have nothing in the TV shows menu.

I’ve tried uninstalling Sapphire, deleting the metadata plist and starting again, even re-installing atvFlash from scratch - still nothing. When I do an import it seems to go through the process of fetching everything, but then when it’s done it says “Updated 0 entries”. This only applies to TV shows - the movies appear as expected.

Anyone got any ideas?

I have tried all of the above as well and am still having the same problem. No new shows are appearing in the TV Shows virtual folder, even though they are all there in the Collections folder and the Import All Data even asks questions about the files.

Suggestions anyone?

I’ve been having this exact problem for the past week or so.

Surely someone can help?

I also observe a similar pattern. I think all the problems in the server TVRage.com
A week before it worked, updates are not installed.
Can anyone help?

I don’t think the problem is with TVRage. If you examine the metadata file all the data seems to be there - at least it does for me. It’s just not showing up in Sapphire. Still no idea why…

I’m surprised and disappointed that the ATV Flash team haven’t seen fit to reply to this thread. Come on guys, earn your money and give us some input.

Am having exactly the same issue, everything was fine & dandy, then went away last week on business & now I have returned, added latest episodes of shows I have, Sapphire recognises them, even asks me to identify the ones it doesn’t know, then says ‘0 entries added’ ?

Strangely it works fine when you import movies (IMDB databases is used to tag movies) so perhaps it is a TVrage issue?

Bump.

If he atvflash guys could please respond to this issue. I paid for support assistance and so far am really unimpressed with the customer support.

Same problem here, thought it was a problem with my install so I restored the Apple TV re-installed latest aTV (which I had to pay for as my subscription had run out) only to discover that it wasnt the problem. Movie appear fine, just not TV. The silence is deafening!

Hi,

I had the same problems … but got a workaround …
I tried all the above hits and had the same problems, I could not find out wich vertion of Sapphire I had wit atvflash 4.1.2, so here is what I did :
Unnistall Sapphire in Maintenence … manage plugins
Install Sapphire (Beta 7.8.2) manually :
got it from
http://appletv.nanopi.net/sapphire-browser-downloads/
and followed the instructions (really symple)
http://appletv.nanopi.net/manual/install-atv/
restart finder …
and there was it , not as Media but as Sapphire, but it worked well I got my TV shows and movies all organized well and TV shows with coverart !!!
The bad is that I’m not managing Sapphire thru Maintance …

But it works for now till atvflash team solves it thru an update.
Francisco

Look like atvflash 4.1.2 still running Sapphire 7.7! until fix of 7.8.1, but that 7.8.2 come out on February 25th, 2010
http://www.atvflash.com/changelog.php
:wink:

Thats all well & good, but:

  1. Why has it suddenly stopped working as has been running happily on 4.1.2 for weeks?

  2. Why should we have to manually hack everything just to get something we have bought working?

  3. When is anyone from Fire Core going to notice this thread & make a comment that this is a known issue & the manual hack suggestion is a workaround that will not cause problems in the future when the next aTV version is released?

AGREE

I’m escalating this issue for what hopefully is a quick remedy.

Sorry for the trouble.

huzzah! Thanks, GuardianMax.

I thought this of problems installing the update Sapphire Browser:
http://appletv.nanopi.net/getFile/Sapphire_1.0b7.8.2.sh
It took a shaman drum:)

An update for Sapphire is now available through the Maintenance --> Manage Plugins menu.

Sorry for any trouble you may have experienced.

Question if we have manually installed latest Saphire using the method listed above, should we leave it as that or run the Maintenance update?

You should be able to run the update without any issues.