Image stuttering on Apple TV HD

Hi, i have these last weeks got some problems with image that stutter a bit, not much but it’s wird.
I havent got these problem before, and i had InFuse for some years now.

I have media on Seedhost and i have set it to “legacy” but no luck, when i play same media (movie) on Plex i dont have the problem.

I use Apple Tv4 HD.

Thanks! :heart:

Have you tried setting the cache to Auto?

Yes… same problem :confused:

Is this happening with all files, or just a few?

Do you have the Match Content options enabled on you ATV?

I have the same issue. Never had stutters previously, now they are constant and with video files that have never had an issue before.

  • ATV 4HD (x2).
  • Synology NAS.
  • SMB shares.
  • Was set to SMB2, now changed to Legacy and will see how it goes.
  • Speed tests from Infuse appear fine and very steady.
  • One ATV is hardwired and one is on WiFi. Both stutter the same way.
  • Stutters for around 10 seconds on every video file start and then every now and then during playback.
  • Restarted the app.
  • Restarted the ATV’s.
  • Unset and then set again for Match Content on each.

Is there anything else I can try?

I literally only use my ATV’s for Infuse, so there’s not much else loaded on them or in use on them.

1 Like

All files… and yes, i have tried that, no luck :frowning:

Did you come up with a Solution? :frowning:

Putting my SMB to Legacy has improved the situation a lot. Although oddly it shows lowers speeds on the speed test than my previous setting (which I think was SMB2).

I’m keeping an eye on it…

Would much prefer this to be sorted though as I’m sure we can;t be the only ones. It was smooth as butter in the past, but it’s so clunky nowadays. Don’t even get me started on the overall lagginess in general and how long it takes to change a video from ‘mark as watched’ to ‘mark as unwatched’ and vice versa.

I Tried that, still problems… have tried to delete app and data also… no luck :frowning:

1 Like

"Same here"™️ ATV4K over Ethernet to a SFTP linux box. Used to work absolutely fine with 4K x265 files but recently developed a very annoying intermittent stuttering. Plex has no issues with the same files. Not happy.

1 Like

Welcome to the forum!

Have you tried the suggestions presented earlier in the thread? If so did it change anything?

Also, what version number are you using for Infuse and for the tvOS or iOS?

I have also noticed similar stuttering on NFS. Very random too.

The stuttering came back for me using SMB. I have a Synology server so I’ve switched to NFS. So far so good…

Same issue here. Intermittent random stutter every now and again. I have match frame rate etc switched on but have noticed this to be a recent problem. I use ftp to a synology nas with strong speeds.

One other thing to try, in the ATV settings under Background App refresh make sure it’s turned on BUT have Infuse as the only app that can use it.

i have sign up for beta versions, hope to get acces asap to see if there are the same problem with Infuse 7…

I tried on a full restored Apple TV 4 (hd)
*Have tried on wired setup/ wifi
*Streaming 1080 mkv files from Seedbox (FTP)
*I have a 500/500mbit connection, but Apple TV only can run 100mbit on wire. (can that be a problem?)

NO luck :frowning:
I have I single frame for one 30 sec that “jumps” … have been using InFuse for many years now, first time I have these problems…

NFS hasn’t helped me. It started good when I changed my shares from SMB to NFS, but it’s back to being laggy as hell to navigate. Laggy as hell to change the watched status. Stuttering when a video file is started, random stuttering when viewing.

Overall I feel like the general experience is declining with Infuse. Which is a shame as it was great once.

I know you’ve been hammering on this a while but have you done a force quit on Infuse and checked after you restart the app?

I had a miserable lag on changing screens and in general navigating around Infuse and this helped for a bit. It started with one of the tvOS 14 updates and seems to be somewhat stable since 14.4.

Also did you try turning off all apps other than Infuse in the ATV settings for background refresh?

Yeah, done that.

Done this also.

I know you’re trying to help, and it’s appreciated (like it is with everyone you help), but I’ve kind of given up now. I’m started to look at other options for my home media.