Im stuck

I hit option and select the IPSW it acts like its going to install and itunes tells me "This APple Tv could not be restored.  This device isnt eligible for the requested build."  I have tried plugging power in, green poison, limerain, snowbreeze, name it I tried it.  Does anyone have any ideas please 2 weeks of trying Im frustrated.

can enyone help?

Me too :-(

me to, im running 4.1 and used Pwnage to JB, got the same message!

I am also suffering from this as well. I have contacted support but no info has been sent to me yet.

Hi there,

I remember experiencing the same problem when trying to jailbreak my iPhone a long time ago. I don’t remember the firmware details but I remember my conclusion was that my current iPhone firmware was not jailbreak-able at the time. I had to wait for a new jailbreak tool to be released for my firmware. It drove me nuts, because pwnage tool would build the IPSW, but it would fail the restore when I would go into iTunes to finish the process.

Anyway, check to see if your atv is running 4.1. If it is, the current jailbreak tools are more or less not compatible… there is a way to do it with some coding and using terminal commands but thats if you don’t mind it being tethered. You would want this, if you move your atv around (unplugging it). The will be coming out with a new tool with a new exploit VERY very soon, and it will be untethered. Sit tight, hope this helps! Good luck.

did you try to put in in dfu before you restore?


try my ispw(search in forum) 

I am having a similar problem.  When I left for vacation everything worked fine.  I returned to a blinking light on my ATV2 (previously JB untethered).  When I connect to iTunes, it sees the device but whenever I try to restore I get the error message that the device isn't eligible for the requested build.  It happens when I try to re-JB with Pwnage Tool or Seasonpass so then I thought I'd just restore to factory settings and just use the ATV in its virgin state for now but it won't restore to virgin state in iTunes either.  When I click restore it goes thru the natural process and at the end i still get the "device isn't eligible" error message!  Any idea how I can restore it back to factory settings.  When I connect it to a TV, I get the picture of the iTunes logo and a USB cable and when I connect it to my Mac I get the error message - all I want to do is restore to factory settings somehow.  HELP!

I'm having this same problem.  When I connect the HDMI all it get is a black screen.