Ifaith stuck on exploitation

I’m trying to dump shsh blobs, but when I do on every Apple TV I have it stops at exploitation and says waiting for Apple TV. Does anybody know who to fix this?

Hi Brad witch atv2 version are you at?


You can only save blobs if your device is already jailbroken.  As you are on 5.2.1 I’m guessing it isn’t jailbroken, so you can’t.  Unless you used the tethered 5.2.1 jailbreak, then you could, but you would only ever be able to restore back to a tethered 5.2.1 jailbreak in future with those saved blobs.

hope still un jailbroken, lets focus on blobs dumping , prepare ifaith 156 or 157 with cable power & usb connected & start dumping the blobs

i saved my blobs unjailbroken twice with 5.2.1 & 5.2


Sorry Blockhead you are absolutely right :)  However in this instance saving version 5.2.1 blobs isn’t going to help much  :frowning:

I’m on 5.2 but can’t save the blobs (never been jailbroken before)… ifaith gets stuck on exploitation (when this happens it seems to have gone out of DFU mode, i open ireb and kick it back into DFU and it proceeds as far as iBEC)

other time gets as far as upload iBEC (depending on the combination of having itunes open and/or power plugged in or not) and it will stay verifying stuff with the APple TV - get stuck there.

I just dumped blobs off a 5.2.1

but can i still dump my blobs on my 5.2 or what?

Try doing it with iTunes open… I had the same problem time after time but then it was suggested to me to try an older version of iFaith and run it with iTunes open.  This combo works more times than it fails.  YMMV.

Dumping the Blobs little complicate not because of process complicate it’s issue where ifaith how to make it work with itune.  I have doing about 20 apple tv last 2 weeks with dumping blobs.  I notice some issue stucck and you have to keep trying and finnally it will goes through.  What was able successfully to manage no getting stuck on exploriation forever.  Please every one has it own it issue based upon on your your computer reacting to the ifaith.

  1. Plug apple tv into computer wait until itune popup then closed if its doesn’t then that good.

  2. open ifaith.  hit dumping blobs. and going throught process on ifaith instruction.

  3. This tricky part where have to do very quick.  looking out your itune applciation will be open on computer as soon as it done dfu mode close the itunes right away… keep look out for the for itune if it open just close it asap…


FYI make sure your apple tv LED Light is blink before starting to do this process if not plug in power cord 30 second the unplug ithe power cord…

did it with an older version of ifaith and also with itunes open  - tried all kinds of combinations at least 10-15 times.

Guru: gets stuck in iBEC mode (used ifaith 1.5.5 and 1.5.7)

i’ve successfully dumped blobs on a 5.2.1 without any probs


I know it isn’t easy for you. I have tried numerous times on just one Atv2. On my windows xp , my apple tv logs shos 100 and on my windosw7 thelast was 64 AppleTVUpdater 64.log. So a total of 164 trials and errors before getting just one right.

So brad how was the 5.21.blobs going . After saving 5.2.1 blobs re open ifaith whichevr version suits you and see if there are any





choose download  the 5.2 blobs or you can download all the other  blobs to experiment yourself.Saved them to a folder.

Also as a combination I also use Tiny umbrella latest 612 & see the connected device ATV2   they show the name. serial ecid & click save SHSH. At the same time open ifaith & re do the blobs until you get it right.


yeah i can’t figure it out - tinyumbrella says device not connected but it recognizes it in the logs and that there are 2 shsh bl0bs on it that can be dumped but won’t dump them
ive tried every possible combination of power + itunes open + disconnect power, etc. over and over again and nothing is doing on this 5.2


i really don’t know what to do next…

Lets see your configurations, Are you on a mac, windows xp or win7 , what kind of usb cable, i use an old NOKIA micro usb cable.

  1. Unplug your apple tv2

  2. Plug just the cable power only & wait until the led stay still & not blinking.

  3. Plug the usb cable. Led should remain stable. Open TU 612 & see if there is any connected device & should read Apple tvname, IOS version, ECID, Serial.

From my own experience with TU the blobs you can see in the log (I have 6) are the 6.1.3 blobs downloaded by iFaith from the Apple server to your PC when it fails to find any on Cydia…

Same thing here

Hi John, have you used ifaith 1.5.6 or TU to check for available blobs?