iFaith SHSH dumps

I’ve been having a lot of trouble getting iFaith to dump SHSH blobs for the Apple TV 2G. It always seems to get stuck at upload iBEC and says waiting for Apple TV 2. 

Is anyone else having these issues? If so, do you have a suggestion on how to get iFaith to complete the dump process?

I had the same problem.

I plugged in the power cord, with the usb cord and iFaith completed the entire process with any issues. Hope this helps.

I’ve tried with and without the power cord and it always seems to hang. I have attempted it on 2 different computers as well. I have had it successfully dump SHSH blobs previously but it seems to take forever and isn’t consistent.

just a quick fyi.  i was having the same problem with 2 different atv2’s  What i did to resolve it was plug into my tv turn on atv go to settings and reset them on the atv.  then when i tried ifaith again it worked fine.

seems there is something that was messed up on both of them but right after reset problems were resovled


hope this helps someone

Thanks for that tip, I’ll have to give it a shot on my next jailbreak.

No problem for me using the ifaith 1.5.6, what I did is open iTunes and leave it there. Then put my Apple TV 2 to DFU, when it reach IBec I plugged in the power cord and it work. I don’t know if it work for everyone.

What is  your apple tv version?  I found iFaith 1.5.5 doesn’t work very well with 4.x atv version.

Does reset help? I used iFaith 1.4.1 and then it worked fine.

I haven’t had an opportunity to test out the reset or using an older iFaith version.

I just replied to this other post:  http://forum.firecore.com/topic/10195#comment-61471


if this is happening on your laptop, try doing the dump from a windows desktop system and see if it works! 

after restoring back  to latest stock firmware ios 6.13 (5.2.1) (un jailbreak ) i tried using i faith 1.5.6 , iwas able to save the blobs of 5.2.1.  Also after downgrading to Ios 6.1 (5.2) & try saving the blobs again still sucessfull.



Maybe you should try to do this:

I had both usb cable & the power cord always plugged in even though ireb shows only the picture of usb cable

After restoring to the stock Apple  firmware & itunes say to to unplug ang plug usb  in the HDMI & connect to TV dont unplug  anything yet but  open Ifaith and quickly save the blobs