If AppleTV will not recognize your flash drive

Hi there. This is just more of a heads up - and does not contain any solutions.

I bought ATVFLASH about 1 week ago. Since then - I have used the installer to create about 15 installs on my flash drive. I factory restore my apple tv about 2 or 3 times per night. The reason is that once I have it installed - I am ssh’ing in and screwing around and eventually break something. (trying to learn more about the hacking etc) Every flash drive creation I do - I also end up choosing a different set of plugins to be installed onto the flash drive.

Point is - my Kingston 1gb flash drive has worked great.

Last night I again factory restored, created a new flash install and it installed fine.

2 hours later - i created a new flash drive - factory restored - and now my usb key WOULD NOT install. it would not recognize my flash drive. WTF? So I created a new flash drive install - and again tried to get the ATV to recognize it and it wouldn’t. it would just keep booting into the regular appletv menu.

So - now I am getting worried.

My flash drive has an LED light on it that lights when data is being accessed. i remembered that usually that light comes on when inserted into the apple tv. but now nothing. so i unplugged the flash - replugged it in. nothing. unplugged, replugged, nothing. wiggled the flash around in the atv usb slot and voila - the light came on - and i rebooted the appletv and it installed fine as usual.

I would suggest anyone having an issue when installing (and your flash drive has a light on it) - reboot the apple tv by pressing volume down/menu for 6 seconds. after about 30 seconds it will give you a menu asking if you want to restart/restore settings/factory restore.

at this point insert your flash drive and take note if the flash drive led becomes active. if the light does NOT come on - as far as i can tell it will not install. and again - i had to replug it a few times and wiggle it in the usb port o make it work again…

hopefully this can help someone…

I have a flash drive I have used on previous occasions and it wirked flawlessly, it doesn’t have a light on though unfortunately.

Here’s what happened, I ran 3.2.2 on my original 40gb and it went well.
I upgraded the hard drive to 250gb and then upgraded to 2.1

sometime in between flashing and upgrading I needed the flash drive ( I don’t know the maker as it looks like a casino chip and is 1gb) so erased the files. Now I reuse it and it won’t seem to be recognised by the atv, I tried what you suggested above and have also bought two 1gb sandisk cruzers and neithe of them work.


thanks for posting this is good info as the cruzers have lights but it’s on and flashes at boot but does’nt even start the atv just reboots.

hey mixxxer,

sounds like either the thumb-drive’s USB connector, or the AppleTV’s USB socket are a bit loose. from what you’ve described it sounds like you’re doing lots of rebuilds, lots of plugging & unplugging. and maybe reaching around to the back of your AppleTV is a little awkward? maybe some of those plugging/unpluggings you’re bending the stick as you insert/remove? i know i do sometimes.

anyway, repeated plugging/unplugging on a bit of an angle could cause the USB socket’s solder joints on the AppleTV motherboard to become ‘dry’ (an electronics term), causing what you describe. or it can happen on the USB thumbdrive too, depending how solidly its made.

if you or someone you know is handy with a soldering iron, it might help to check and probably touch-up the USB socket’s solder joints. i cant remember if the USB socket’s PCB connections are thru-hole or surface-mount. if thru-hole then you’ll have to completely remove the mobo to get to the solder joints on the underside - which is a bit of a bitch.