Idx/sub-files not playing

I have tried to find assistance for getting vobsubs (.idx/.sub files) to play, but so far I’ve had very little luck. I find no help/guidelines. When viewing the subtitle menu, the subtitle file is appears as “movie name.sub” (without quotes), but the subs are not visible. The movie is located in a folder on my NAS (SMB), and the folder structure is;

Movie name

  • movie name.mkv
  • movie name.idx
  • movie name.sub

The subtitles play just fine in VLC, and even on my NAS’ movie app, but it doesn’t play in Infuse (not on my Apple TV 4k, and not on my iPad/iphone)

Can someone kindly offer assistance, please? What am I doing wrong?


Unfortunately IDX/SUB pairs are not currently supported in Infuse. This is something we hope to look at for a future update, but we don’t have any kind of ETA right now.

Standalone .sub files are supported.

Seems like this has been a requested capability for years - what is so difficult about providing it?

Use this: Convert Sub/Idx to Srt: easy online format converter | Subtitle Tools

Any news on this?

You can track what’s on the near horizon in features here Upcoming Features (updated 12/19/23)

Since this is a thread that has been marked solved from nearly two years ago you may want to search the suggestions forum to see if others have made a suggestion to support this feature and if not, you can start one there.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.