iCloud syncing not working

Just bought v5 pro, and added a share (sftp). Customized some of the fetched metadata that was wrong, and expected to see those corrections when I added the same share on my iPhone, but I do not. iCloud syncing is enabled on both the aTV and iPhone.

I looked in “Mobile Documents/iCloud~com~firecore~infuse~5” and I see a “Documents” folder, but no files at all.

Any advice?

A few things to check

  1. You’re logged in using the same Apple ID on all devices.
  2. iCloud Drive is enabled (https://support.apple.com/en-us/HT204025)
  3. On the Apple TV, at times, you may need to exit the app after creating a share in order for iCloud to pick up the changes.

When iCloud sync is working, the share you setup on the Apple TV will sync over to your iPhone, so it won’t need to be set up again manually.

Thanks, James, that helped. I hadn’t thought to check to see if I was still logged into my iCloud account on my aTV. I was logged out (but it remembered my ID). The same share now appears on my phone, just as I wish. Where are the metadata files stored on iCloud Drive?

Great!

Actual metadata and artwork aren’t stored in iCloud (Infuse’s cache can run into the hundreds of MBs for a typical library and most people are on the free 5GB iCloud tier) but Infuse will maintain a list of items you’ve made manual changes to, and keep those in sync between devices. Other things like saved shares, playback settings, Up Next list, will also stay in sync.

Additionally, if you log into trakt your watched history and playback progress will also sync between devices.