iCloud Sync MacOS (iCloud account not found)

Dont really use Infuse all that much on my Mac but figured now we have errors I can hopefully troubleshoot it here.

iCloud Sync has never worked on my Mac but does on all my 3 ATV’s and two iPhones, the error I now have on my Mac since the update is ‘iCloud account not found’

Curious error seeing as my iCloud account is 100% logged in and present on my Mac in the same way it is on Infuse.

I have checked in MacOS settings it its not showing Infuse as using iCloud where it lists all the other apps that are. I have latest MacOS and all that.

Given this is the error I am getting, can anyone point me to a fix or something to investigate?

Thank you.

Mine doesn’t show Infuse in the apps using iCloud either on the MacOS but mine is syncing fine. Just curious, in the Infuse settings under “Sync” iCloud Sync" is checked correct?

Oh ok it’s not that then.

Yeah it’s checked dude.

Okay, I dug a bit deeper and under MacOS settings where you click on your User ID and then click iCloud where it says Apps using iCloud there’s a “iCloud Drive”, click that and then click on “Apps syncing to iCloud drive”. This is where Infuse is showing and is checked as on.

1 Like

Yeah this is the area I mean.

Infuse is not there at all so I can’t check it as on there. (It’s checked within Infuse). Sorry if I confused your question.

Yes it’s checked in Infuse App
No Infuse is not present in the MacOS settings at all.

Hmmm, maybe a re-install.

A silly question but since I think iCloud sync is a “Pro” feature maybe check and make sure your Infuse didn’t lose it’s Pro status? If it reverted to the free version it may not access iCloud.

Yeah funnily enough I checked that as well, says I’ve got my yearly subscription so that’s all good.

You know this app has been installed forever and ever, I think perhaps I’ll uninstall it tomorrow and install again, perhaps that iCloud stub did not get added to macOS.

1 Like

If that works, let us know. Hope you get it sorted.

Might be totally off base here, but if I recall correctly, the AppleTV might be logged into an account different than the one that purchased Infuse — but Infuse doesn’t support multiple accounts so wouldn’t know this.

I believe I’ve seen issues that were only solved when users made sure their AppleTV / Apple Store accounts matched the accounts that their premium versions of Infuse were purchased from.

Is there a chance you don’t see Infuse in Cloud Sync options because you purchased or installed it while using a different account? And it might be trying to sync with that different account? Or a different regional App Store?

Yeah it’s worth checking but I have the most straight forward Apple setup ever. I’ve had the same email ID and associated Apple account in the same region since year dot.

I’m going to try uninstalling and installing soon and will let you know.

1 Like

Mate I’m so sorry, I was reading these messages on my phone and it didnt click to actually go inside iCloud Drive rather than just the settings, in fact iCloud drive was disabled entirely on my Mac for some reason. Indeed once it was enabled I was provided a list of apps that were storing data there and one of which was Infuse.

This is a case of someone just being tired from work and late at night and I’m sorry I didnt read your post properly because it has indeed solved the issue. Funnily enough I solved it my self and then came back here thinking I bet that this is what NC actually said to do :slight_smile:


Hey, I’ve used the same explanation for many of my posts. I think it’s mandatory to be a bit sleep deprived to function here. :rofl:

Really glad you got it back on track and hope it works as advertised! :+1:

1 Like

What is this “sleep” thing you speak of? I am unfamiliar with the concept.

1 Like

Well thanks for the help all.

Also since infuse added the error messages it at least started the journey to the fix! So props to the devs also.

Early night tonight.

Wonder what other benefits I’d been missing with iCloud Drive switched off on my Mac :thinking:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.