iCloud Sync Broken?

I have been able to get iCloud sync to work—ever. I used to use Infuse on my MacBook, iPad and Apple TV 4K. But each had their own ‘database’, despite all being on the latest versions and having the iCloud sync ON on all devices. I thought perhaps I turned on iCloud sync on all 3 devices at the time when there was never a backup and hence it caused some sort of ‘mixup’ resulting in no sync ever.

So, I erased Infuse from all of the devices and decided to start afresh. I now have Infuse ONLY on my Apple TV 4K. Wanting to ensure that it all syncs up OK before even trying to install it on any of my other devices.

On my Apple TV, my iCloud account is signed in to the Default account; iCloud sync is turned ON in Infuse, but I get iCloud sync failed, with no error code (which is what some seem to be getting).

As observed in the above screenshot… I have over 10GB of storage space left on iCloud too. So I don’t think space is an issue.

Any suggestions? Thank you.

You may want to try launching Infuse and going straight to the Library settings page where it shows you the number of movies and tv show episodes and watch the messages below that. Wait for the fetching to finish and then it should go to iCloud syncing. Stay on that page until it finishes. It may take a bit but keep it from sleeping and wait. You should get a message on the right side of that page saying last synced Today… or something like that.

You can try clicking on the Sync with icloud button and waiting for the sync to finish too.

Hi @NC_Bullseye. Clicking on the ‘Sync with iCloud’ does not seem to be doing anything for me. Nor does waiting for, over 20 minutes yesterday, at that page without letting it go to sleep. :frowning:

Back at that page… waiting.

Another easy test is to restart the ATV and then do the above and see if it will sync then.

Hi @NC_Bullseye.

Tried the following —

  1. Turning iCloud sync off; restarting the Apple TV; and then turning iCloud sync back on;
  2. Restarting the Apple TV multiple times;
  3. Signing out and back in to iCloud on the device;
  4. I even waited without letting the device going to sleep for over an hour.

Still… no luck.

Sync with iCloud (last: failed) :frowning:

When you restart the atv and then launch Infuse and go directly to the Settings/Library page do you ever see “syncing with iCloud” here?

Nope. Never.

Tried another thing—

  1. Deleted the app from my AppleTV and restarted the AppleTV
  2. Installed it on my MacBook
  3. Setup my library and rebuilt some collections as a test
  4. iCloud sync form MacBook is successful
  5. Went back to the AppleTV and re-installed the app
  6. Opened it and waited…
  7. …and waited…
  8. …and waited.
  9. iCloud Sync is ON (in the settings). But it is not sync’ing.
  10. Said iCloud sync failed within the Library tab.

:frowning:

Installed Infuse on the iPad…

It seemed to have found ‘something’ on iCloud—and began showing ups my shares. But not everything that is supposed to sync seems to.

  • Saved networks shares (address, username, password, etc…) — SYNC’ed
  • Saved Favorites — NO SYNC
  • Saved homescreen layouts (Lists & Favorites) — NO SYNC
  • General settings (iOS backups only) — NO SYNC
  • Direct URLs added via ‘Add Files’ on iOS/macOS — N/A
  • Textual metadata — N/A
  • Manual metadata corrections (corrections for mismatched titles) — NO SYNC
  • File specific playback settings (selected audio/subtitle track, zoom setting, etc…) — NO SYNC
  • Downloaded subtitles — N/A
  • Playlists — N/A
  • Collections — NO SYNC

I’m close to giving up on this.

If you’re able to submit a report from your device (and post the 5 digit code here) we can look into what may be going on here.

Hi James.

2Q2VF is the code I am seeing on my AppleTV.

The iPad and Mac seem to be syncing (to a certain extent). But the AppleTV isn’t fetching anything.

Thanks.

According to your logs it looks like there is no iCloud account configured on the Apple TV.

Failed to fetch iCloud user. Error <CKError 0x283851440: "Not Authenticated" (9); "No iCloud account is configured">

The most common reason for this on the Apple TV is the ‘Default’ user has not been set correctly. We’ve seen a few cases where there is only one user logged into the Apple TV, but for whatever reason this account is not tagged as Default.

To check this:

  1. Navigate to Apple TV Settings > Users and Accounts
  2. Look for the ‘Default User’ heading and click on it
  3. Confirm the correct Apple ID is listed under iCloud
1 Like

Hi James.

Yes. The correct iCloud account is registered under the ‘Default’ user on my AppleTV.

Don’t the iCloud and Store accounts need to be the same?

Edit:

I guess not:

https://support.firecore.com/hc/en-us/articles/115000070773-iCloud-Sync

NOTE

All devices: It’s possible to login using separate IDs for iCloud and the App Store. To use iCloud Sync you will need to use the same ID for iCloud on all devices. The App Store IDs can be different, if needed.

NOTE

Apple TV: It’s possible to have multiple user profiles set up with different Apple IDs. To use iCloud Sync, you will need to ensure the Default User is using the correct iCloud ID.