I suddenly have no sound whatsoever for SOME of my macs

Hello all,

I downloaded and installed atv flash a couple of nights ago, but was having some problems getting some of the features to work, and then mucked around some with a few settings.

Today, out of the blue, I tried to watch an episode of The Office (one that I actually had watched – and, more importantly heard – without difficulty the night before) and found that I had suddenly lost sound for all of the following:

  1. all files on my streamed macmini (music and video, encoded in various ways)
  2. all music files on my mac pro (which is considered the appleTV’s main collection)
  3. all menu navigation sounds (and yes – I have navigation sounds set to on
  4. youtube
  5. a local video_TS file I had transferred to the HDD to check on TS file playback

Prior to today, I had no sound issues whatsoever with any of these sources.

Frankly, I now can get no audio whatsoever except for 2 things:

  1. the intro when the appleTV is booting up
  2. all of my Handbraked movies (made with the ‘appleTV’ profile) on my mac pro – DD 5.1 passing fine, even a 1.0 movie (Double Indemnity) passed fine audio-wise.

So, I have audio from my handbraked movies, but not from ANY of my music on my mac pro, and I have no audio whatsoever from ANY files on the macmini.

In a moment of frustration, I decided to reset the appletv to factory settings with the plan of starting from scratch all over again, re-loading with flash, etc.

Unfortunately, even after I did so, the appleTV still has the same issues. :oops: So, now, I have atv flash uninstalled, but I don’t even have appleTV’s basic out-of-the-box functionality anymore.

I get the distinct feeling that my problem is now nigh-to-unfixable absent getting a replacement…

One note that may be of some utility – at one point, I removed 2 sources from the ‘audio blacklist’ (I honestly don’t remember the exact phrase) in some portion of the DVD sub-menu. I had (and still have) no idea what the significance of this move could be, but it seems as if it was somewhat temporally related to my newfound problems.

I would GREATLY appreciate any help, as my appletv is now pretty much useless. :frowning:

 My friend had the same problem.  He did everything under the sun to fix it.  Then realized he had the tape monitor on his amp selected.  Hope that wasn't your problem.

Alright, well now I’ve decided to try to add my macbook pro’s media collection, as I hadn’t added it prior to doing the factory restore.

Unfortunately, I get no audio from any of those files either.

So, whatever the problem is, it applies to any new macs with which I decide to connect as well.

I love my applebrick :?

Sorry for the trouble. It’s hard to say what caused this as you’re not sure what settings were changed.

Probably the simplest way to correct is perform a Factory Restore through the Apple TV Settings > General menu. Update the Apple TV to 2.1, and reinstall the aTV Flash software.

Make sure you select Factory Restore, and not simply reset settings. The factory restore will erase all your synced media, but it will give you clean slate to start from.

Yeah, I had done the factory restore yesterday. That’s what worried me even more – that it had persisted even AFTER the factory restore…

Last night, when I hooked it up in another room via HDMI, all was well, which narrowed it down to the optical port, and made me a lot more sure it was a hardware issue, rather than anything atv flash (and, particularly, my screwing around with atv flash) had done.

This morning, after probably 30 unsuccessful reboots and power cycles, it suddenly worked just fine via optical again.

Now, as to whether or not I’ll return the unit anyway, just in case – I’m still not sure.

Thanks anyway. :slight_smile: