I cannot update, help please

I don’t know what to do. I’m trying to update to 2.3. In the tab settings-general-about it says I’m on 2.0 but when I try to update software it says I’m uptodate and says something like it can’t do it now try again later. My ethernet cable is connected and I can surf the web. I don’t know if there is a setting in thr actual ATVFlash I’m using that prevents my ATV to update. Any idea about this? It is driving me crazy. Thanks

Please view:

http://forum.atvflash.com/viewtopic.php?f=5&t=795

Thanks a lot.