I can no longer connect to my NAS

Frustrated as nothing seems to have changed. The NAS appears in the shares list but when I try to connect it says “problem trying to connect”

Where do I start with troubleshooting? The NAS can connect fine to all other devices.

First, what device are you having problems with? ATV, iPad, iPhone?

Second on the device that you are having problems with, can you connect to the NAS with any other apps?

What protocol are you using?

it won’t let me add the share. I am doing this on Apple TV.

I can connect to the NAS on my MacBook. I don’t use any other apps.

Protocol - SMB

Thanks very much

VLC is a freebie for ATV and it can do SMB, you may want to try that and see if you can connect from it. Trying to determine if it’s an ATV issue or an Infuse issue.

Also, what version numbers are you running for tvOS and for Infuse?

I will see if I can get VLC to work and report back.

I have just removed Infuse from ATV to reinstall it. Earlier this evening I updated to Apple TV (I have been away for a while) so now it is on the latest version but this problem pre-dates that.

Now when I try and install Pro6 it wants me to pay? I am a lifetime member. How do I instal (presumably) Pro 6 rather than standard 6?

There are two different versions of Infuse on the app store, “Infuse Pro 6” and “Infuse 6”.

You’ll want to download the “Infuse 6” NOT the Infuse Pro 6"

The Infuse 6 is the one that works with subscriptions including the “Lifetime” subscription.

Edit to add: When you DL the Infuse 6 app you’ll then click on the “Restore” button next to the subscriptions.

If that doesn’t work make sure you are logged into the app store AND iCloud with the same user id.

I had connection trouble also with tvos14 and infuse 6.5 on my iPad although iPhone and atv and girlfriends iPad were fine, no matter what I tried it wouldn’t connect, in the end I deleted and redownloaded the app and it’s working now.

In iOS 14 (doesn’t currently apply to tvOS), Apple added a new security/privacy setting for local network access.

Infuse will ask you about this when opening it for the first time on iOS 14, but the option can be changed later in iOS > Settings > Infuse. This will need to be enabled for Infuse to access any devices on your network.

thx. does that mean if I want pro I need to buy it extra? lifetime only allows the basic version?

mine was actually already set to this strangely.

No, the Infuse Pro version 6 on the App storeis a one time purchase and is version 6 only. You can’t get upgrades to version 7 and beyond.

The Infuse 6 version is a free version but with a subscription you can upgrade it to Pro with all of the pro features. The difference is when your subscription lapses when you choose monthly or yearly your copy will revert to the basic free version. This is where the Lifetime subscription comes in, if you get the lifetime subscription you will get all upgrades to the Pro version including version 7, 8 and so on for the one time purchase of a Lifetime subscription.

If you got the lifetime subscription then all you need to do is to DL the Infuse 6 non pro version and restore the lifetime purchase to get the pro features. This costs you nothing. Just hit the restore button.

Understood thanks.

Using bonjour discovery this morning I can see the NAS shows twice, once under its name and once under its IP address.

Screenshot 2020-09-22 at 06.37.04

In MacOS the same happens. I don’t think I recall seeing this before. Could it be confusing Infuse?

Screenshot 2020-09-22 at 06.44.24

Is your Apple TV connected via Ethernet or Wi-Fi?

Are you using a dual-band router?

We’ve seen a few cases where devices may be available on one router band (and ethernet) but are not accessible on another band.

Can you try changing the connection type on the Apple TV (Wi-Fi > Ethernet, or vice-versa)? You can also try connecting your MacBook via the same method as the Apple TV to see which devices show up.

I have also noticed that the NAS is showing as “unreachable” through my iPhone app prologue, which attempts to read the Plex server from my NAS.

Therefore I think we can assume the issue is that the NAS has become unreachable for some reason, but it remains reachable from my MAC. Do you have any advice as to how to trouble shoot here?

It works neither on wifi nor on ethernet. Where do I go from here? This is incredibly frustrating please help

Disable any and all firewalls and other security features on your NAS. Can you reach it via IP through the Files app?

Did you get this sorted out @paul_doran?

I’m wondering if it may have be an IP address issue, (only guessing), static IP perhaps??

It’s very strange. I deleted Infuse, rebooted the NAS and started over and now it works fine. These sort of reboots are really annoying. I can’t think what caused it

How is your network setup? Is it a pretty basic one where everything is connected to a router or are you using managed switches and vlans?

NAS has an ethernet cable into router. Apple TV is connected to ethernet into router! Couldn’t be simpler!