Is there anyway to get hulu running on my atv2?  I tried looking in XBMC but could not find anything.

Try posting your question in the ATV2 portion of the Forum…

Yes, here you go:

Thank you for that link.  I’m just a little lost when it comes to navigating to that zip in xbmc.  Any idea how I am supposed to get xbmc on my apple tv to find that?  I’m just a little lost on the process.

Here’s another link that explains it in better detail than I can:

I generally FTP the .zip file over to the AppleTV’s “/private/var/mobile/Media” folder. Then in the Add-ons section of XBMC’s prefs, I “Install via zip”

Then I restart XBMC, then go to Videos -> Addons, and add in the new one.

Since I have xbmc running on my pc with hulu, is it possible to just somehow have xbmc that is running on my atv2 recognize whats on my pc in regards to hulu?

I tried to ftp the zip, I really mucked it up though, I’ll just keep looking for better instructions on how to do it,  thanks for the help

thanks again.  Using cyberduck I was able to get it up and running (the user name and password were the problem.)  everything is loading up just fine in xbmc, the problem now is when I go to watch a show I get the error message…playback failed, one or more items failed to play check log for details.  Any idea what this means or how I go about fixing it?

nice work!

the final piece of the puzzle I had to do was replace the librtmp.0.dylib file.

follow the notes here:

thanks, I feel like I am so close.  Well, I went back and deleted the file and then uploaded the new one.  I must have done something wrong because when I went to play a show, instead of getting the old error message apple tv summarily crapped its pants.  I now have to tether boot back up.  Any idea where I could have gone wrong?

Sorry, no idea… this would be the thread to ask, though…

Thanks again, I appreciate you taking the time to follow this.