How to.. MiRow, Front Row and Lion

Okay, I took the plunge and installed the Patched version of Front Row along with MiRow on Lion and it works great as far as I can tell… and have been able to test… over the last 24 hours.

However, be aware there may be issues that I have not uncovered yet, but so far, so good!

Instructions

First, make sure you have downloaded MiRow 1.04 from Firecore (Maybe other, older versiuons work too but I used the latest 1.04 for my testing)

Next, download the patched Front Row installer from the following address;

Front Row Lion Enabler/Installer

Install the Front Row Enabler/Installer.

Restart Computer.

Install MiRow

Move Front Row icon from Apps to Dock (Optional)

Run Front Row

Hey Presto… MiRow on Lion :slight_smile:

Enjoy!

Mag66

After further testing today… I have come across a couple of problems…

  1. On a computer which already had Front Row, MiRow and Snow Leopard working fine and then ‘upgraded’ to Lion followed by my previously described method of installing Front Row and MiRow, I found that only the Internet Menu addition to Front Row worked… No sign of the other additional menus though Perian installed fine and by using aliases in the Movie Folder I was able to watch any movies (Divx etc) via Front Row but then, if you install Perian manually yourself, this can be achieved without the use of MiRow anyhow.

However, the Internet Menu option did work and worked well… so that is down to MiRow working correctly within Lion.

 

  1. On a freshly installed Lion (New Partition and no previous OS installed) I got the results I noted in my first post but then, after a few more reboots I lost all the extra menus with the exception of the Internet Menu as described above. They just stopped appearing.

 

  1. On an upgraded Snow Leopard to Lion setup with only Front Row previously installed (I had never installed MiRow on that computer under Snow Leopard…) after following my initial install method, I got no extra menus at all. In otherwords, no MiRow working… Odd, to say the least.

 

I think with a bit of work and exploration by Firecore, these little bugs could be fixed as maybe it’s just an issue regarding ‘hooking’ into the install of Front Row more than anything else? Finger crossed!

At least nothing crashed or corrupted during the process which leads me to believe it could all work with the right ‘fixes’

Mag66

I have tried this proceedure exactly as listed and in my case MiRow does not work. All the FrontRow menu items are there, Movies, TV Shows etc but none of the MiRow meus appear. I have checked 

 

/System/Library/CoreServices/FrontRow/Contents/PlugIns

And all the MiRow stuff, Sapphire.frappliance, LastFM.frappliance, RSS.frappliance, Weather.frappliance, etc. are there but they do not populate when I launch FrontRow.

I hope that there is something that Firecore can do or someone can work out, I regularly use MiRow and Front Row and this will prevent me from upgrading any other computers that I have.

Thanks

 

 

Are you seeing the Internet Menu?

 

Mag66

Yes you are correct I can see that one menu only, the rest do not populate

 

Okay, that makes sense… as I am now seeing much the same here on all but one of my systems…

 

One for Firecore to sort out I suspect…

 

Mag66

Interesting workaround - we’ll have to give it a try.

Would be good if we can get some official support here…

Any news on getting MiRow working with Front Row in Lion?

I would love an update on this!  I don’t own MiRow (yet), but would buy it if it supported FrontRow on Lion as described in this thread.

Other media players are impressive, but the simplicity of FrontRow is amazing, and perfect for family use.  Especially families with small children!

I’m new to Apple, so I am amazed that they have dropped FrontRow from Lion.  It’s stellar!

So, obviously, I’m really praying I can add MiRow to this Lion reincarnation of FrontRow!

Please?