How to edit / delete a source I added to XBMC?

does anyone know how to edit/delete a source I added to XBMC? I added a SMB source from my network but it has a typo so cannot be found, it just sits there when I search sources but I cannot delete/edit it. tried pressing menu or play/pause button but no success. Any idea?


SSh into the machine and edit the “sources.xml” found in /Users/frontrow/Library/Application\ Support/XBMC/userdata/sources.xml on your AppleTV.

ooops. so no GUI for dummies like me?

You can SSH using WinSCP on a windows box or muCommander on Mac OSX. Then everything except the text editor for doing the changes will be GUI-based (and even that one depending on how you count).

There is a simpler way then editing an xml file.

Select the source and hold down the menu button on your AppleTV remote. It will then launch a contextual menu with the option to remove source.


BTW, found this on the xbmc online manual…specifically this page

Google is your friend…

I expected this but did not succeed as I get no context menu when tried this approach. will try again…

Hm, tried this. Have to correct my initial statement. I can delete the source once added if I select Video and the I see the sources and can delete from there. But this are the sources I added via SBM and which got a ‘nice’ name like DVD, Movies or Kids. However, I once added a source to the search list, i.e. when I want to add another source then I get the menu where I can select e.g. from SBM, uPnP etc. and here I once added a SBM source which I misspelled. ~ instead of -. And that one I cannot seem to delete from the list. Any ideas? Maybe I should post a screenshot but wouldn’t be able to tell how to make one on the ATV, well except by taking a real photo.


if it doesn’t give you the option to remove source in the context menu, then the only other option would be to copy the xml file mentioned before and delete it using a text editor, save the file and copy it back to the AppleTV overwriting the file there.

my sources.xml file looks like

<video> <default pathversion="1"></default> <source> <name>Video Playlists</name> <path pathversion="1">special://videoplaylists/</path> </source> <source> <name>Movies</name> <path pathversion="1">/Users/frontrow/Movies/</path> </source> <source> <name>NewStuff</name> <path pathversion="1">smb://</path> </source> <source> <name>iPod Movies</name> <path pathversion="1">smb://</path> <path pathversion="1">smb://</path> <path pathversion="1">smb://MACBOOK/ipod movies/</path> </source> </video>

If I wanted to remove the NewStuff source, I would delete


using a text editor (notepad on windows, textedit or something similar on OS X) and save the file, then copy it back to the folder.
When you relaunch XBMC, the source should be gone from your list.

Just wanted to let you know that it worked. Got the stupid source deleted. Though - as I tried to explain before - I did not really mean ‘sources’ but the ‘links’ I can use to add sources from (Hm, if that helps to explain what I mean), anyway: they solution was to edit another files but the sources.xml, cannot remember the name but it was in the very same folder.

Happy camper again

This is obviously a problem with the interface. Hopefully someone from Boxee is monitoring this thread and this gets fixed in the next release.

Here's a simple way to delete the media source for APple TV 2 - [HOW-TO] - Removing Video Source from XBMC List (Apple TV 2)

holding down the menu key does not work for this a bug?? i was able to do it to one entry but that was it.

Can someone give me a step by step of how to SSH into the sources.xml and change everything? i am new to all this and still learning.



same here!


please, can anyone help us??

i really need to delete a SBM source which I misspelled.


can anyone help me?


i already tried holding down the menu button on my Apple TV remote and it did not launch the contextual menu with the option to remove source.


how can i delete those 2 smb sources that i added?  already tried everything that i know but nothing has worked. can anyone help me? tks in advance!


Hey Daniloss,

I had the exact same problem.  Got some hints from this thread and got me headed in the right direction.  Not sure what OS you are using, but I am using Apple TV 2 recently jailbroken with EDEN.  Anyway the filename that is mentioned throughout this thread is wrong, and so is the location.  Here is where I found the file I needed to edit.


Inside of that folder you will find a file called “mediasources.xml” that holds the config that you are referring to.  The file name mentioned earlier, “sources.xml” holds the config for what you would see under the Video heading in XBMC.

I used ssh from a linux terminal to get access to the file.  sftp://root@  This can be done from “terminal” or “Nautilus”.  Nautilus is easier cause you get the GUI you were looking for.  You can also do it from Windows.  Download a program called WinSCP.  It is very straight forward.  Just enter the ip address of your apple tv and the user and password.  Mine is freshly jailbroke, and the user is “root” password is “alpine”.

Hope this helps you, and if not someone else.  It was driving me crazy too. :slight_smile:


I’ve discovered that it depends which skin is installed as to whether holding down the MENU button brings up the menu. I use Confluence and it works in there. When I used other skins the MENU button did not always bring a menu up.

Also, you need to “press & hold” the MENU button down as opposed to “press it”.


Had the same problem today, took a few minutes to find where it was located. Follow these steps, if you’re on a Mac:


  1. Open Terminal (Utilities folder) and type: ssh frontrow@(IP address) (unless you’ve changed the user/pass)

  2. If you haven’t done the previous step before, it’ll ask you to trust the RSA key, type ‘yes’ without quotes.

  3. Enter the password frontrow (unless you’ve changed the user/pass)

  4. Change your directory to Library/Application\ Support/XBMC/userdata/

  5. The extra \ in the line above is to add the space between the words. If you’re going through one folder at a time, you can type ‘cd Application*’ instead (without the quotes). Once in the folder, type ‘ls’ (without quotes)

  6. You should see a file called ‘mediasources.xml’. Type ‘nano -w mediasources.xml’

  7. The above opens up an editor. Arrow down to the lines you want to delete, and delete them. Once they are gone hit CTRL-O to save, hit enter to accept the saved file name, then hit CTRL-X. This will exit you out of the Editor and you’re done. You can do the same with sources.xml as well.

Please keep in mind that you must be careful when deleting things from these files. Only delete the single, whole line as it appears:

<location>Other stuff here including the name of your link and the destination</location>

That’s it.

Using the apple remote worked for me. Not at first. 

First of all it operated just like a "back" button but with some perseverance it worked. Just make sure you're holding it firmly and not wavering - needs a consistent signal. 


After about 4 attempts it worked.