How to deal with multiple versions of same movie


I have several movies which I’d like to keep in at least two versions — one in Blu Ray and one in DVD (different cuts, commentaries, etc). Since Infuse doesn’t support version selection from one folder (outside of Plex sources), I’ve resorted to keeping them separately and having two separate posters also.

The problem is, no matter what folder structure/name I try, Infuse always shows them both movies with same poster. It also seems random, for some reason it sometimes shows the first, other times the other. Grrrr!! See my sample of Hollow Man attached.

How are you folks dealing with multi-version movies? Obviously, ideally, I’d love Infuse to treat multi-versions in a folder same way as it does for Plex sources — keeping them under one movie item and allowing version selection on Play. But oh well, it doesn’t :frowning:

1 Like

Most people deal with this topic by adding their support to a currently running thread in the suggestions forum here Multiple versions of a movie :wink:

Ah, thanks. Though that thread feels more like a feature request discussion. I wrote this thinking this is clearly a bug? The custom poster in the folder is simply ignored and randomly showing a completely different poster…

You can try doing a long press on the folder that has the movie, metadata xml file, and artwork in it and select “Use Local Metadata” and see if that helps.

OK! That has fixed it it seems. I’ve set the SD version to None - use embedded metadata, even though there’s no embedded metadata in the file and the custom posters are now respected in both movies, even after viewing their details screens.

I’ve then created a custom xml metadata for the SD version and it shows nicely. Perfect! Thank you.


  • Why do I have to choose use embedded metadata if there’s none in the file?
  • Why selecting to use the actual metadata xml file, instead of none, messes up the posters again?
  • Why isn’t the custom poster jpg simply always taking preference in the first place? (Just like it does for single-version entries)

I mean, your workaround works, so I’m happy for now and will wait for native multi-versions (if/when it gets implemented). But wouldn’t you say that my bullets above describe quite an unexpected behavior? Especially second and third bullet totally feels like a bug to me hm

Check out this thread i started… kind of goes inline with what you’re talking about :slight_smile:

Glad that worked for you!

First we’re talking about two different things when we use embedded metadata and local metadata. The Embedded setting uses metadata that is actually located within the file while “Local” is metadata is located along side the video file.

The only time you should have the Embedded metadata option turned on in the settings is when your files have actual embedded metadata. Otherwise you’ll often end up with trash graphics that others may have put in touting their services and such. Best to leave this setting OFF.

Here’s where the fun begins. When you have the “Fetch Metadata” turned on in the Infuse settings Infuse will first look at metadata files both text and art that are located along side (Local to) the video, then if none exist it will then go out to the databases and download the metadata. This is usually the best way that I can tell unless you’re ripping all of your own files and including the metadata within that rip.

When you choose the Use Local Metadata option on a folder it’s telling Infuse to not fetch any additional info and this is how it knows to ignore metadata for what appears to be the same title (but different file) and not try to duplicate them since Infuse tries to remember any edits you do for a title.

Now keep in mind, this is just how I personally understand things and there could be some grey areas where I’m in the twilight zone but for me it’s been working this way and I don’t monkey with things too often. :wink:

We’re trying to combine the several threads relating to handling multiple copies of a movie here Multiple versions of a movie so you may wish to add your support there instead of starting a new thread. Thanks :slight_smile:

I got Use embedded metadata disabled in settings. I have no posters embedded in my rips (all my own rips). So far so good.

Yes, but no, but yes, but no. I got Fetch Metadata enabled in settings and every movie has a local poster jpeg next to it. From what you’re saying, it should first check if local art or text exist and if doesn’t, only then fetch from online. This works perfectly for me, yes, for any/every movie which I got only one version of. It respects the local poster and only fetches the text meta.

But, BUG1:
As soon as I got two versions of a movie in two separate folders, each with a different jpeg poster, then:

  • on first initial scan, both movie versions display their respective individual poster
  • after visiting the details screen of either of them, suddenly both movie versions will show the same poster — the one of which details screen I invoked!
    This is clearly pictured on the screenshot in OP. I mean you can clearly see both versions have same poster, why is one of the local posters ignored? When even you said just now that local art/text have preference. That’s clearly not the case in the folder structure I got—with two versions of the same movie.

The workaround you suggested, and it works, is very misleading. I literally had to select Use embedded metadata on one of the versions, even though, once again, I have no embedded metadata in my rips. Why do I have to select embedded meta in order to show the local poster? If I had selected to use movie-name.xml for metadata on one of the versions — the duplicated poster bug is back. I mean, sorry, no matter how I look at it, this reads as a bug to me. Is it not?

Okay, it seems I’ve got you on the wrong track. I’m used to using the ATV version and not the iOS version. I just went through the iOS version and in order to use “Local” and NOT “Embedded” you have to go to the three dots at the top of the screen, not long press.

If you navigate to the movie you want to follow your xml and artwork instead of the metadata fetched info you go to that movie the tap the three dots it should give you the option for “Use Local Metadata”

I’m still trying this for the first time but that’s the difference, you need “Local” not Embedded" if you select embedded Infuse will still try to replace it when you have duplicate titles. Sorry I can’t be more detailed but I’m figuring it out as we go. :slight_smile:

Sorry @NCBullseye we simply don’t understand each other.

I’m not questioning where to set to use embedded metadata. Embedded metadata is completely irrelevant here. The issue is with local artwork. It’s also irrelevant whether you proceed with the steps on iOS or tvOS. What I’m saying is:

  • :white_check_mark: local artwork is correctly preferred and shown for single version movie
  • :white_check_mark: local artwork is correctly preferred and shown for each version of a multi-version movie, but only on first scan
  • ? local artwork in a multi-version movie is ignored, and replaced with the artwork of the version of which details screen has been visited at least once
  • ? to work around this, user has to manually override the affected version of the movie’s metadata to none - use embedded, even though the movie has no embedded metadata
  • ? selecting to use the local metadata does not show the local artwork included in the folder, it shows the artwork of the other version!

I mean, it can’t be any clearer than this, sorry. This is at least two bugs—if you look at my screenshot in OP there’s no way you can’t see how wrong it is. If you recreate the folder structure and try to reproduce the issue you will understand that this has nothing to do with embedded meta, nor with iOS vs tvOS. This is a bug in how the local artwork is (not) fetched for movies with same title and multiple versions (folders/files).

Sorry, your correct. I was not where I could create a test group and work it out.

It’s not working quite as I was understanding how it was supposed to work. I don’t know if it’s a bug with the software or with my understanding of how things are supposed to work :slight_smile:

Sorry for adding to the confusion, I’ll keep hammering on this till hopefully one of the many more qualified folks chime in.

Seems these types of quandaries always come up on the weekends. LOL