How to access SMB shares on my NAS

I have an unraid NAS which has several SMB shares (i.e: movies, music, tvShows…).  When I go to add a share in Media Player, it scans my network and lists all of my computers including my NAS, but it does nto see any of the shares on my NAS.

I tried selecting my NAS and editing the Server to be MYNAS\movies and then when i tried to test the connection it just hangs there forever.  it cant seem to connect.

I tried saving that path and it scanned for media and found none.

So can I go about adding my movies and tv shows that live in the SMB shares on my unraid server?

Did you enter your username and password for your share on the ATV?  I believe that is why it is not showing any folders.  It needs your username and password to access them.  

After it scans for your NAS select it.  Then enter your username and password (that you set your NAS up with).   Test connection then save…  Hope this helps.  Good luck 

Hey thanks for the reply.  I did not enter any username or password because there is no username or password set on the shares on my unraid server.  When i connect to them from any other device i am not prompted for a username or password, so I assume that those fields shoudl be left blank here right?

You should leave them blank if there’s no username/password set. Firecore has published a fairly extensive Knowledge Base entry on what you’re trying to do (I used it and was able to connect to my NAS shares):

Hey thanks. I actually found another post that suggested using the other type of slashes in my path and that seemed to do the trick. Although testing the connection and fetching metadata are VERY slow.

Would using thee this in nitoTV as suggested in the link
You posted make this work any faster or better?