How does InFuse mount NFS locations?

I have a mixed library of 1080p BD rips and 4K UHD rips, some in raw BDMV folders and some converted to MKV files (no xcode, just re-containerized).

FreeNAS 11 NAS connected to a Netgear WiFi AC1900 router, which connects to a Verizon Quantum gateway router. AppleTV 4K connects to the same network via an Actiontec router in MOCA mode (Ethernet <-> Coax <-> Coax to Quantum GW router).

I have exported a Movies folder on my FreeNAS server for InFuse to connect.

Recently I started noticing that all my 4K UHD content (regardless if they are in raw BDMV format or MKV file format) is buffering.

Having done some investigation around NFS performance issues, I came across rsize and wsize settings that can be given to the mount command to address perfrormance issues.

e.g.,
https://www.tldp.org/HOWTO/NFS-HOWTO/performance.html
https://wiki.archlinux.org/index.php/NFS/Troubleshooting

Few questions:

  1. How does InFuse mount NFS folders?
  2. What settings does it use?
  3. Is it possible to provide explicit options for the mount command to help experiment with the performance related issues?

Is there any documentation on how InFuse mounts NFS locations?

Is it possible to change mount options?

I would possibly try connecting both the NAS and ATV to the same router with ethernet and see if your problem still exists. Also do you have match content settings enabled on ATV?

I had them connected via Ethernet at some point, and even in that scenario I would experience the buffering with UHD streams, especially the UHD rips of How to Train Your Dragon 3 and Avengers Infinity War (haven’t tried many others).

What is peculiar is that the buffering will happen after 20~30 seconds of perfect streaming (with lots of high motion activity on screen), and then, it will sit and start buffering for 15~20 seconds. If feels like a buffer is being underrun and the app(?) is trying to re-fill it.

From what I remember infuse should buffer as much as it can into whatever free space you have left on your AppleTV. If your AppleTV is packed full of apps you’re going to have a much smaller buffer.

I deleted a bunch of unused apps but buffering is still there.

What should the match content setting be?

Also, do we have someone from InFuse to comment on the mount options?

Match content and frame rate should all be set to on.

I run FreeNAS on my NAS box with NFS shares, all defaults. The only time I had buffering issues with 4K remuxed media was when the AppleTV 4K was connected via WiFi. I switched it over to Ethernet by plugging the Apple TV 4K directly into the router (Nighthawk R7000) and no issues since.

Have you tweaked any settings on the Router itself, or is it on defaults?

In the end what helped me was to set Match Content to OFF for both and changing the TV type from YCbCr to RGB Low. I know the first part goes against common recommendations here, but that’s what worked (??).