How do I remove and re-install aTV Flash?

Can’t get anything to update through Manage Extras; Maintenance, Media Player, XBMC…all I get is the spinning wheel and the message saying it’s installing but nothing. I’ve left it for ages and just have to stop it. I even downloaded the dmg to my computer and tried to update the whole of aTV to 1.3 but seem to be stuck on 1.1.1 and the update failed.

I even had a go at clicking Submit diagnostics and again the wheel spun with nothing else happening.

As far as I know my connections are fine (I can watch movies from my hard drive and stream Trailers from the Movies tab.

I’d like to remove aTV and reinstall (without having to re-Jailbreak as that is a nightmare for everybody I think!)

How do I do that or does anyone have any other suggestions. 



OK now when I try to update Maintenance it fails and in the Log i get the following message:

E: dpkg was interrupted, you must manually run ‘dpkg --configure -a’ to correct the problem.


How and where do I do this. I’d still rather start from scratch as I can’t seem to uninstall XBMC. Another new problem is that I can’t seem to access my computer any more through aTV flash. I can get to files on my Time Capsule and attached HDs but as of yesterday i cant watch stuff on my computer. error is AFP connection failed: unreachable network or incorrect login/password

It’s getting frustrating

Managed to fix the latter problem: for no apparent reason I had to unshare then Share my computer with my aTV!

The easiest way to correct any dpkg related errors is to simply re-run the aTV Flash (black) installer from a Mac or PC.

[[wysiwyg_imageupload:151:]] Tried to reinstall but got this failure dialog box


















I have the same problem…


What to do???

Just to let you know davidr.36840 I didn’t get this sorted and ended up restoring my ATV. Unfortunately this meant getting the latest software, which seasonpass can’t jailbreak yet…so I’m stuck with plugging my MacBook into the tv for the moment.

Shouldn’t be too long to get that fixed though.