High bitrate files ALL buffer at 5 seconds - then they play perfectly the rest of the file

I know that buffering is a constant topic but my situation (may, I haven’t searched the entire forum) be unique or at least unusual.

I’m using an iPad via a strong 5 Ghz connection. The video files I’m viewing (mov or mp4) are from my DJI drone and are all 40 mb/s or higher bitrate. No matter if I pick a 1080p30 or 4k30 or above (anything higher than 30 mb/s seems to be the point where this occurs) the video buffer for approx 5-8 seconds then start playing smoothly. It will play for 5-6 seconds (never less or more) and then buffer for 5-8 seconds. Then it continues to play the rest of the file (10 seconds or 20 minutes) without any further buffering, smoothly.

I’m mentioning this so the developers can see it and perhaps identify what is going on with initial buffering vs buffering after the first attempt and “fix” this.

Thanks in advance, I hope this isn’t a redudant post.

(Great product, the ONLY one I could find for AppleTV that will play 4K video without buffering)

Welcome to the forum!

Have you tried as a test to download one of the videos that you’re experiencing difficulties onto the iPad and see if it plays without issues?

If so it may be the protocol you’re using. SMB 3 can cause problems when the security associated with it causes delays. In those cases, switching to SMB 2 or “Legacy” has remedied the problems. Also others have found issues with their wireless routers throttling the streams on the local network and have had to be granted a priority over other devices on the network.

1 Like

A 5Ghz connection won’t be good enough to stream that high of bitrate if it’s only 5Ghz-N. you’ll need at least a 5Ghz AC

There’s really no hard and fast rule when it comes to WiFi speeds. Even having a 5Ghz AC connection doesn’t mean you’ll have no issues since theoretical speed and real world results are often vastly different.

A solid N protocol could theoretically support the videos in question.

1 Like

The bitrate is 30 mbs, when I run speed tests my connection handles my 150 mbs internet download speed so I’m reluctant to think it’s purely bandwidth.

This would ignore my primary point: at the 5 second mark it buffers (typical of low bandwidth or not enough pre-caching) BUT then, for the rest of the file, it plays just fine with no further buffering. This happens with any file over 25 mbs bitrate. Even 80+ mbs 4K files play the same, play 5 secs, buffer, play without buffering.

Thank you for your reply

For a bit of background, when starting files Infuse will attempt to start them immediately with minimal buffering. If the connection is fast enough to keep up, it will then continue playing with this minimal buffer.

If Infuse senses the connection is a bit slower, it will automatically increase the buffer. This is likely what is happening when you see a 5 second pause. Additionally, .mov files in particular can have some strange characteristics which require additional buffering.

We’re working on some pretty big changes in this area for the upcoming Infuse 6 release, which we believe will improve streaming in just about all cases. For now, if you’re using SMB, you may try switching the version from Auto to SMB2 or legacy to see if this helps at all.

Now that is a very helpful reply (thank you everyone else too, no slight intended) and sounds like what I was expecting . I’m holding off purchasing the $50 version to verify v6 works as expected or better. I have many 80mbs files from my drone I would just about kill to have stream without buffering on my big screen via AppleTV. I’ll then go laugh at the VLC guys