Help with setting up a share via WebDAV (HTTPS)

I have Infuse Pro 3.3.1 on my iPhone. I have a web server running IIS with WebDAV installed and configured to use HTTPS. I can connect successfully using OS X’s built-in WebDAV client. However, when I use the same settings in Infuse, all I get is a generic error message saying “An error occurred - Unable to connect to server.” My MacBook and iPhone are on the same WiFi network, so I know there is nothing preventing Infuse from actually finding the server.

Has anybody had any success setting up a WebDAV (HTTPS) share? Is there any kind of log I can check to see what is going wrong with Infuse as it tries to connect? I don’t see anything in my server logs that even shows Infuse trying to connect.

I got it working. However I’m using a NAS share that can be accessed by HTTPS WD2GO. If you can log in to your server via Web browser (I used Google Chrome). Once logged in I right clicked and selected “view page source”). I then searched for “parameters”. What I used in infuse as the address was not the https address (Portal URL) but the “host” url I found (in my case it looked like this “wdmycloud-deviceXXXXXXX.wd2go.com” The username and password that I used in infuse was not my log in credentials for the drive but the info I found in “parameters”. There I found “deviceuserID” and used that as user name for infuse and “deviceUserAuthCode” information was the password for Infuse. For the path that depends on the share you want access to. I had to do it for each share. I entered path as “/share name_” (without quotes obviously). I’ve not tried leaving the path blank to see if it just loads all shares. Hope this works for you.

Oh, and reading your post again webdav (https) setting for Infuse did not work using these settings when I was on LAN this would appear to just be a way to connect via WAN (you mentioned mac and iphone on same network). Inside your home network there are better ways to connect to your server (SMB).

I meant to post an update to this, guess I forgot. I looked into the logs (see http://support.firecore.com/entries/26759150-Submitting-Diagnostic-Logs) and the problem was that my IIS server runs SNI on the certificate. I opened a bug for Firecore to look at their SSL library to add SNI support. Not really anything to do with WAN vs. LAN. Bill, if you can’t reach your WebDAV share through the external name, you likely have some kind of DNS issue. That’s kind of like saying “I can’t access my HTTP server inside my own network, I guess I should use SMB to open my website”.