Help with Router Issue PLZ

Hello all, I need some help.
For quite some time, I have been using an Asus RT-AC68U as my router. I haven’t had any issues with my AppleTV Infuse app seeing shares and streaming video from my media server based on a PC on the network.

I have now upgraded my network both in speed and hardware. I am now using an ASUS GT-AC5300, and I know that this router has many more security features than the AC68U.

Although every device I have on the network works and connects to the net without problems, my AppleTV Infuse app no longer sees my media server’s shared folders, in fact, it cannot see the server at all.

Anyone know what the issue(s) may be? I’ve had to reconnect the AC68U and create a separate network just for the ATV Infuse app to stream from the media server.

I have updated the firmware on the AC5300 … updated the software on the ATVs, reset the network to default … nothing seems to work.

Help plz

Give these tweaks a shot and see if they help with your issue

  • Turn off AiProtection
  • Enable UPnP
  • Disable Network Services Filter
  • Check your SMB versions to ensure compatibility

Just note, if you use a UPnP or DLNA connection you’ll lose many of the features in Infuse.

Having it active on your router isn’t an issue but just don’t mistakenly pick that as a connection protocol. SMB or FTP usually works best.

Thank you for the reply …
I’ve had those tweeks already in place, still a no go …
The only other piece of information is that all the ATVs are wireless.
If connected wired, they see the shares … I’m at a loss.

Take a peek at your router’s admin panel and head over to the “Wireless” settings. Just make sure the security settings and encryption are in sync for both the 2.4 GHz and 5 GHz bands. Also, look out for “Wireless Isolation” or “AP Isolation” and disable it for both bands. Oh, and don’t forget to switch off “Airtime Fairness”. Once you’re done, hit reboot.


Well Neofire, I think that did the trick!
I turned off the “Airtime Fairness” in the Wireless setup … also, making sure the security encryption was in Sync… Couldn’t really see that in the settings, put pointed me to “Enable Smart Connect” that basically combined all 3 of my wireless networks into 1 broadcast. That did the trick!! I didn’t even have to delete and re add the share!

Thank you all for all your great suggestions!!
Happy viewing!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.