Help with Movie Filenames


So happily having finally gotten all my TV series dialed in [so much of my aggravation turned out to be caused by my using unapproved middot separators • doh! :man_facepalming: ], I’ve begun working on verifying my movies.

I’d discovered Infuse sometimes gathered the wrong metadata for some of my movies (admittedly due most often to the non-standard way I named my movie files, or their mismatched theatrical release years compared to TMDB’s database), but I didn’t notice because (unlike with TV shows) Infuse (properly) overrides TMDB’s poster and fanart with my local artwork and movie titles with the customized title text included in my local .nfo files.

Originally I’d only notice when I’d try to use Infuse’s nifty search feature to find movies (by title, or actor, or crew member, or movie series collection) and movies I knew were in my collection did not appear. After such discovery, I’d go a little insane trying to figure out what happened (I struggle from severe OCD, clearly).

Eventually it occurred to me that the best way to search for movies in my collection that weren’t picked up correctly by Infuse / TMDB on initial import was to (1) delete my database and batch-rename all my local metadata .nfo and .jpg extensions so Infuse wouldn’t see them prior to (2) re-running a new collection import —— and then looking in my library for (3) titles placed in Other category because TMDB couldn’t find a match and scrolling through my imported folders with (5) in list view (6) with option Show Filenames enabled visually searching for (7) mismatches between my filenames and the movie posters displayed (which would have been downloaded anew from TMDB).

So, here’s my first quandary following this process:

The movie is the outstanding “Moon” from 2009. It’s named “Moon (2009).mkv”. Infuse / TMDB identifies it instead, frustratingly, as “The Twilight Saga: New Moon” (also from 2009).

Edit to add: Also discovered same issue with “Lion” from 2016 (scraping as ‘The Lion King’ even though that movie came out in 1994!) and I can’t figure out a way to scrape the 2nd movie to come out in 2017 with the exact title “Escape Room”…

How do I resolve this?

TMDB search seems to default to illogical choices when movie titles are short and more popular titles share common words.

Who do we talk to about that? I mean, you’d think if I actually had “The Twilight Saga: New Moon” I’d have put “Twilight” in the filename. Or, at the very least — the word “New” (as in “New Moon”).

I think you’ve got a curse.

Here’s the file names I used (note no parentheses)
FLskydiver file names

Here’s the results Infuse retrieved automatically with no editing needed.

Are these the right ones?

Edit to add, I see you said the second release of escape room for 2017. I clicked on the “Edit” button on the pre-playback screen and here’s the suggestions.


Is the one you want the one below the one with a check? If so that’s an easy fix, just select it and your good to go.

Write that instead as “I think you’ve gotta curse.” and you’re describing my situation 100% correctly.

I did notice earlier that Moon started working. I didn’t change anything — somebody must have changed something after I posted on TMDB.

Still no bueno on “Lion”, though — parentheses or not. I get same results from web search on TMDB.

And yeah, the “Escape Room” movie wanted is the 2nd one. I guess the only way to get that to work is finding out if there is an alternate title.

Or just deleting it from my collection since I’ll probably never watch it anyway.


I see what you’re getting in TMDB, what are you getting in Infuse? That’s where they will show correctly. You may have to do an Edit to get them to see the changes but it will work.

On the escape room, click on edit in Infuse and it should show you both of the 2017 releases and then just select the one you want. As to the others they’ll come up correct with the name change and an edit to select the right one, save the curses for the neighbors dog at 3 in the AM.


Only Kodi’s python API pulls the correct result without user needing to correct it.

On the plus side, these may be (as far as I’ve to date determined) the last two titles I haven’t been able to scrape correctly (on Import to a new Infuse library) out of the 2,991 titles currently in my movie collection and 194 series in my television collection (down from at least a couple hundred prior). Yay!

Okay, it looks like you still have the parentheses in the title and that may or may not be one of the gremlins but on the Lion phone screen even though you have "the lion king checked isn’t that the correct movie just below that?

Can’t you just check that movie and have it corrected? Secondly if that doesn’t stick, have you tried entering the movie name on that same edit screen above the selections in the box using the keyboard?

I don’t have any of those three or four movies and all I can tell you is that using Infuse 7.3 and the file names I showed it pulled the correct metadata in seconds of opening the folder with them in it.

I don’t use any plex, emby, jellyfin, jellyfish, jellybean, or peanut and jelly servers, just Infuse. I still believe that with an edit you can get the last two hold outs in time for Christmas. LOL

Sorry things have drug on for so long but aside from that, have a wonderful holiday and enjoy “watching” for a while instead of wrenching on the back end. :christmas_tree:

1 Like

I’ve tried removing parentheses but it hasn’t made a difference.

Of course I can get it right by manually moving the check — but since I frequently rebuild the library and need to do so on multiple devices, I don’t want to have to remember to do so each time. I just want it to work! I mean, I’m so close now!

Maybe I’ll wake up tomorrow and it will finally stop insisting “Lion” is really “The Lion King” (which I already have in my collection elsewhere, anyway) … it would be a Christmas Miracle™.

Have a happy holiday. :slight_smile:

Watch?

I never watch movies. I only read about them, look forward to new releases, eagerly acquire discs or downloads, spend hours ( … days … years ) organizing them, making sure they have accurate metadata; downloading aesthetically pleasing posters and fanart images (often photoshopping my own when not satisfied with current offerings), keep on top of backups, and making sure my monitors and home theater gear are properly, precisely calibrated. Who has time to actually watch anything??

Are you my long lost identical twin brother from the Sunshine State???

:rofl: :rofl: :rofl:

Your brother from another mother. Lol. :grin:
Cheers! :beers:

1 Like

So I noticed this past hour that when I did a manual edit metadata search on my Apple TV for “Lion (2016)” on my Apple TV, that “The Lion King (1994)” is no longer an option — neither the first result, nor, curiously, any other — for this movie.

That struck me as peculiar, since I had just minutes before checked again on both my iPhone and themoviedb.org and “The Lion King (1994)” still ruled supreme … as ‘King of the metadata usurping Jungle’, you might say.

So, what was the difference? My Apple TV had updated to Infuse Pro v. 7.3 (3947); while my iPhone was still on the previous version. So I update my iPhone, and my copy of “Lion (2016)” magically updated to the correct movie (from its previously incorrect assumed identity as 1994’s The Lion King).

So, this makes me think someone at Firecore must have changed something in Infuse. If so … First and foremost - Thanks! …

But I’m also curious. Was this a change in code to address this very specific title or something that applies to all titles globally, in a way that just happens to address title mismatches such as this one?

A response I received to a post I made on TMDB noted that the reason ‘The Lion King’ appeared as an answer to the query Lion y:2016 was, apparently, that The Lion King had its Armenian television premier in 2016 (per IMDB; a release that is 2nd from last in a list of hundreds). Not sure why that alone would merit an identification of “The Lion King (1994)” over the seemingly obvious choice of “Lion (2016)” for the query “Lion (2016)” … but did someone at Firecore figure out a way to overrule such (il)logic and decide to change the way Infuse processes search results or submits its queries?

Wonder if it is part of this new feature in 7.3:

  • “Added year filter in edit metadata search”
1 Like

One other possibility to the change is that maybe iCloud sync had been keeping a previous selection (Lion King) as a correction and it took all devices to get on the new correct selection for it to take hold and replace the Lion king. I’ve had some sticky iCloud corrections it took a week to appear on all devices.

Me, too. Good catch.

I don’t use iCloud sync.

It seems perhaps not the wisest thing in the world to choose to share the un-encrypted contents of my personal media collection with a company which not only is a major content distributor but also quickly becoming a major content creator?

Found another one:

“Spider (2002)” being incorrectly identified as “Spider-Man (2002)”.

Honestly, I don’t understand why the best possible match isn’t the default.

Clearly if the thinking is “he named the file ‘Spider (2002) but he definitely must have meant ‘Spider-man (2002)’ because that’s a more popular movie and he probably just got too tired to type out the whole thing” … well, that’s just daft.