Help with Jailbreaking ATV2 4.0 (iOS 4.1 - 8M89)

I received a brand new ATV2 from a friend with software version 4.0 (iOS 4.1 - 8M89) . I’ve been trying to jailbreak using both the latest and the oldest version of seas0npass but with no success. The problem is, in seas0npass, when I right click to create custom ipsw, I don’t see the option for my firmware version. I’m not sure if I can update the firmware to say a 4.4.4 and then do the jailbreak. I’ve spent days searching the internet for any options but to no avail. I’ve also tried to use other jailbreak options like greenpois0n but still not working. I’m very confident I can find a solution from this forum. Any help or info will be greatly appreciated. I do not want to update to the new 5.0 firmware that was released on march 7th. Thanks.

Well you could try sn0wbreeze. It appears to support 8M89. If it is not available in the menu for Seas0nPass then it doesn’t support it.

You can download sn0wbreeze from http://ih8sn0w.com

Yeah, sn0wbreeze didn’t work either. It got stucked on the updating patch screen for well over 3 hours. I don’t know if it’s a windows 7 issue.

I am running the Simple Mode here now. If you want to post your SHSH blob I can see if I can patch it for you. But that still leaves you in a predicament of how you’re planning on flashing this. Unless your blobs are stored on Cydia.

I saved my SHSH blob locally using iFaith. I’ll post it when I get home after 5pm ET to see if you can patch it. Hopefully, I can use the instructions from step 6 below at this link http://forum.firecore.com/topic/7279 to flash it onto the ATV 2. Thanks for your help.